summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-kernel/linux
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-01-24 13:28:33 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-01-27 16:56:15 -0800
commit6c77f60835dfe9fad99dbf0e6c4212069e30f378 (patch)
treea216531574b1732042bacbce32e97f88ee1392c5 /meta-romley/recipes-kernel/linux
parent19aef8f203a043059fc5a4b5a73a7ed6e27ef13e (diff)
downloadmeta-intel-6c77f60835dfe9fad99dbf0e6c4212069e30f378.tar.gz
romley: Set PACKAGE_ARCH to MACHINE_ARCH explicitly
The new intel-common.inc sets the default of the PACKAGE_ARCH for the linux-yocto kernel recipes to DEFAULTTUNE_kernel. Revert the existing recipes to MACHINE_ARCH until they can be removed in favor of a more unified mechanism. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-romley/recipes-kernel/linux')
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend3
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend3
-rw-r--r--meta-romley/recipes-kernel/linux/linux-yocto_3.8.bbappend3
3 files changed, 9 insertions, 0 deletions
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 3ec22528..49498dcd 100644
--- a/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_romley = "${MACHINE_ARCH}"
4PACKAGE_ARCH_romley-ivb = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_romley = "romley" 6COMPATIBLE_MACHINE_romley = "romley"
4 7
5KMACHINE_romley = "romley" 8KMACHINE_romley = "romley"
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
index fc2c3037..1da1b56e 100644
--- a/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_romley = "${MACHINE_ARCH}"
4PACKAGE_ARCH_romley-ivb = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_romley = "romley" 6COMPATIBLE_MACHINE_romley = "romley"
4 7
5KMACHINE_romley = "romley" 8KMACHINE_romley = "romley"
diff --git a/meta-romley/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-romley/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 0264c227..d0b2f834 100644
--- a/meta-romley/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-romley/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_romley = "${MACHINE_ARCH}"
4PACKAGE_ARCH_romley-ivb = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_romley = "romley" 6COMPATIBLE_MACHINE_romley = "romley"
4 7
5KMACHINE_romley = "romley" 8KMACHINE_romley = "romley"