summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-09-28 16:03:16 +0800
committerSaul Wold <sgw@linux.intel.com>2015-09-29 18:05:49 -0700
commit84c049b9cb80b50fd32b716c2ae97e3f0d4e3cd7 (patch)
treeef1fb0171d8e087a7d4f7d1b04a8d9b59c522801 /meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
parent5e218aeacace801c4f01a1db8c99ac8a51421661 (diff)
downloadmeta-intel-84c049b9cb80b50fd32b716c2ae97e3f0d4e3cd7.tar.gz
meta-intel: meta-romley BSP retirement from YP 2.0
Remove meta-romley BSP layer from meta-intel master branch which is targeting for YP 2.0. A heads-up email was sent to the meta-intel mailing list for requesting any feedback regarding retirement of these BSP. Since there is no concern, we assume that it is agreed upon and thus this patch to retire the BSP. The "MAINTAINERS file" and "conf/machine/README file" are updated to reflect removal of the BSP. We expect intel-corei7-64 machine is continued to be used to support the platform and dpdk recipe under meta-romley is now supported under meta-isg/common/recipes-extended/dpdk. Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb')
-rw-r--r--meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb b/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
deleted file mode 100644
index 581f1d4a..00000000
--- a/meta-romley/recipes-extended/dpdk/dpdk_1.7.0.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1include dpdk.inc
2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.7.0-examples-Add-config-variables-to-enable-disable-dpdk.patch \
5 file://dpdk-1.7.0-examples-pipeline-build-with-all-examples.patch \
6 file://dpdk-1.7.0-ring-remove-extra-devices-creation-with-vdev-option.patch \
7 file://dpdk-1.7.0-ring-simplify-unit-tests.patch \
8 "
9
10SRC_URI[dpdk.md5sum] = "07907d7b1a64888a459a971c45818038"
11SRC_URI[dpdk.sha256sum] = "aafc290260b5002d248ab8f8c8ffa76454d4b1382aa3c82ae2700ecce481397a"
12
13export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
14
15# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
16# fuse is in meta-filesystems and qat is not yet upstreamed.
17# So adding mechanism to explicitly disable the use of fuse and qat.
18# To enable, uncomment the below line or include in .bbappend.
19# PACKAGECONFIG ?= " dpdk_qat vhost "
20
21PACKAGECONFIG[dpdk_qat] = ",,qat"
22PACKAGECONFIG[vhost] = ",,fuse"
23
24do_compile_append () {
25
26 cd ${S}/examples/
27
28 # Disable the compilation of example apps dpdk_qat and vhost if they are
29 # not included in the PACKAGECONFIG
30 export CONFIG_EXAMPLE_DPDK_QAT=${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}
31 export CONFIG_EXAMPLE_DPDK_VHOST="${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
32
33 ###############################################################
34 # In order to make use of dpdk.inc for example app installation
35 # without failure, override the default build directory
36 ###############################################################
37 oe_runmake CROSS="${TARGET_PREFIX}" O="${S}/examples/$@/"
38}
39
40
41