summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-09-28 16:03:16 +0800
committerSaul Wold <sgw@linux.intel.com>2015-09-29 18:05:49 -0700
commit84c049b9cb80b50fd32b716c2ae97e3f0d4e3cd7 (patch)
treeef1fb0171d8e087a7d4f7d1b04a8d9b59c522801 /meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
parent5e218aeacace801c4f01a1db8c99ac8a51421661 (diff)
downloadmeta-intel-84c049b9cb80b50fd32b716c2ae97e3f0d4e3cd7.tar.gz
meta-intel: meta-romley BSP retirement from YP 2.0
Remove meta-romley BSP layer from meta-intel master branch which is targeting for YP 2.0. A heads-up email was sent to the meta-intel mailing list for requesting any feedback regarding retirement of these BSP. Since there is no concern, we assume that it is agreed upon and thus this patch to retire the BSP. The "MAINTAINERS file" and "conf/machine/README file" are updated to reflect removal of the BSP. We expect intel-corei7-64 machine is continued to be used to support the platform and dpdk recipe under meta-romley is now supported under meta-isg/common/recipes-extended/dpdk. Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb')
-rw-r--r--meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb b/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
deleted file mode 100644
index 72f57683..00000000
--- a/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1include dpdk.inc
2
3
4SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
5 file://dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch \
6 file://dpdk-1.6.0r2-app-test-fix-build-switches-to-enable-cmdline-tests.patch \
7 file://dpdk-1.6.0r2-eal-fix-option-base-virtaddr.patch \
8 "
9
10
11SRC_URI[dpdk.md5sum] = "f406d027320fc8e724bff20db5397cbb"
12SRC_URI[dpdk.sha256sum] = "e72fdebcf8a899fc58e60c9b6493b7457576eece60b08dea6aee96c9087df4b2"
13
14export EXAMPLES_BUILD_DIR = "build"
15
16do_compile_append () {
17
18 ###################################################################
19 ### Compilation for examples
20 ### Skip dpdk_qat due to it has dependency with qat source code
21 ### Skip vhost due to it has dependency to fuse libraries
22 ### Skip vhost_xen due to it has dependency to xen libraries
23 ###################################################################
24 for app in ${S}/examples/*
25 do
26
27 [ `basename ${app}` = "dpdk_qat" -o `basename ${app}` = "vhost" -o `basename ${app}` = "vhost_xen" ] && continue;
28
29 cd ${app}
30
31 ###############################################################
32 # netmap_compat is putting the binary in a directory path
33 # which is different from rest of the example apps, so this
34 # special case is handled here to avoid installation failure
35 # with dpdk-1.6.0
36 ###############################################################
37 if [ `basename ${app}` == "netmap_compat" ]; then
38 oe_runmake CROSS="${TARGET_PREFIX}" O="${app}/bridge/${EXAMPLES_BUILD_DIR}/"
39 else
40 oe_runmake CROSS="${TARGET_PREFIX}"
41 fi
42 done
43
44}
45