summaryrefslogtreecommitdiffstats
path: root/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-11-06 07:05:52 -0600
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-11-06 10:55:26 -0600
commit0f6d30a95c84ec239f5a30bbfba17ed42e2cf284 (patch)
tree768a8dc74cb17cdfa009ba12c241c5fd4f68751c /meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
parent567358dae4a005e09b37311beed78ca923cb4aad (diff)
downloadmeta-intel-2.0-dizzy-1.7.tar.gz
common: Remove DPDK recipes2.0-rc4-dizzy-1.72.0-dizzy-1.7
Move the DPDK recipes out of common/ and into meta-romley/. The DPDK recipes have so far been shown to be broken for any other machine than Romley or for any other kernel version than the kernel Romley is still using, 3.10. So the logical place for them to live would be in meta-romley, if anywhere. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Acked-by: Burton, Ross <ross.burton@intel.com>
Diffstat (limited to 'meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb')
-rw-r--r--meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb b/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
new file mode 100644
index 00000000..72f57683
--- /dev/null
+++ b/meta-romley/recipes-extended/dpdk/dpdk_1.6.0r2.bb
@@ -0,0 +1,45 @@
1include dpdk.inc
2
3
4SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
5 file://dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch \
6 file://dpdk-1.6.0r2-app-test-fix-build-switches-to-enable-cmdline-tests.patch \
7 file://dpdk-1.6.0r2-eal-fix-option-base-virtaddr.patch \
8 "
9
10
11SRC_URI[dpdk.md5sum] = "f406d027320fc8e724bff20db5397cbb"
12SRC_URI[dpdk.sha256sum] = "e72fdebcf8a899fc58e60c9b6493b7457576eece60b08dea6aee96c9087df4b2"
13
14export EXAMPLES_BUILD_DIR = "build"
15
16do_compile_append () {
17
18 ###################################################################
19 ### Compilation for examples
20 ### Skip dpdk_qat due to it has dependency with qat source code
21 ### Skip vhost due to it has dependency to fuse libraries
22 ### Skip vhost_xen due to it has dependency to xen libraries
23 ###################################################################
24 for app in ${S}/examples/*
25 do
26
27 [ `basename ${app}` = "dpdk_qat" -o `basename ${app}` = "vhost" -o `basename ${app}` = "vhost_xen" ] && continue;
28
29 cd ${app}
30
31 ###############################################################
32 # netmap_compat is putting the binary in a directory path
33 # which is different from rest of the example apps, so this
34 # special case is handled here to avoid installation failure
35 # with dpdk-1.6.0
36 ###############################################################
37 if [ `basename ${app}` == "netmap_compat" ]; then
38 oe_runmake CROSS="${TARGET_PREFIX}" O="${app}/bridge/${EXAMPLES_BUILD_DIR}/"
39 else
40 oe_runmake CROSS="${TARGET_PREFIX}"
41 fi
42 done
43
44}
45