summaryrefslogtreecommitdiffstats
path: root/meta-romley/conf
diff options
context:
space:
mode:
authorKishore Bodke <kishore.k.bodke@intel.com>2011-10-27 14:21:43 -0700
committerTom Zanussi <tom.zanussi@intel.com>2011-10-28 00:04:20 -0500
commit478969defe862a2779bf7eb3bca30e2067827d7e (patch)
tree7f4eca944555205306c3a9d2145268a31cead89a /meta-romley/conf
parentb5c9f0af18b80c2b4c478fd7cfb537e0a04a4e22 (diff)
downloadmeta-intel-478969defe862a2779bf7eb3bca30e2067827d7e.tar.gz
New Romley BSP created. Uses Matrox MGA graphics driver.
This layer provides new BSP meta-romley. This provides the support for Romley + Patsburg Chipset for Intel Systems. Romley refers to the Intel Rosecity Board. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-romley/conf')
-rw-r--r--meta-romley/conf/layer.conf10
-rw-r--r--meta-romley/conf/machine/romley.conf46
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-romley/conf/layer.conf b/meta-romley/conf/layer.conf
new file mode 100644
index 00000000..c5eeaaba
--- /dev/null
+++ b/meta-romley/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "romley"
9BBFILE_PATTERN_romley := "^${LAYERDIR}/"
10BBFILE_PRIORITY_romley = "6"
diff --git a/meta-romley/conf/machine/romley.conf b/meta-romley/conf/machine/romley.conf
new file mode 100644
index 00000000..38bd17a8
--- /dev/null
+++ b/meta-romley/conf/machine/romley.conf
@@ -0,0 +1,46 @@
1#@TYPE: Machine
2#@NAME: romley
3
4#@DESCRIPTION: Machine configuration for Sugar Bay systems
5# i.e. Sandy Bridge + Patsburg Chipset
6
7require conf/machine/include/tune-x86_64.inc
8
9MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
10 acpi serial usbgadget"
11
12KERNEL_IMAGETYPE = "bzImage"
13
14PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
15PREFERRED_VERSION_linux-yocto = "3.0%"
16
17PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
18PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
19PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
21PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xorg"
22XSERVER ?= "xserver-xorg \
23 xserver-xorg-extension-dri \
24 xserver-xorg-extension-dri2 \
25 xserver-xorg-extension-glx \
26 xserver-xorg-extension-extmod \
27 xserver-xorg-extension-dbe \
28 xserver-xorg-module-libint10 \
29 xserver-xorg-module-xaa \
30 xf86-input-mouse \
31 xf86-input-keyboard \
32 xf86-input-evdev \
33 xf86-input-synaptics \
34 xf86-video-mga \
35 mesa-dri"
36
37SERIAL_CONSOLE = "115200 ttyS0"
38
39MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
40
41IMAGE_FSTYPES ?= "ext3 cpio.gz live"
42
43GLIBC_ADDONS = "nptl"
44GLIBC_EXTRA_OECONF = "--with-tls"
45
46MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub"