summaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2012-01-10 08:49:31 -0800
committerTom Zanussi <tom.zanussi@intel.com>2012-01-17 13:35:19 -0600
commit4f1ca13b5a39f27bd41c0c7d9f2b163c3f9e8718 (patch)
tree11cc71ba67e0812c4f9687d13a91df3fd95a1338 /meta-n450
parentfad30a44da749bc966cb2d27dc75b4ead15f94f2 (diff)
downloadmeta-intel-4f1ca13b5a39f27bd41c0c7d9f2b163c3f9e8718.tar.gz
n450-audio: drop this machine specific recipe in favour of alsa-state
Signed-off-by: Joshua Lock <josh@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/conf/machine/n450.conf2
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio.bb30
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio42
3 files changed, 0 insertions, 74 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
index 3e6a5418..6ffdce99 100644
--- a/meta-n450/conf/machine/n450.conf
+++ b/meta-n450/conf/machine/n450.conf
@@ -14,5 +14,3 @@ XSERVER ?= "${XSERVER_IA32_BASE} \
14SYSLINUX_OPTS = "serial 0 115200" 14SYSLINUX_OPTS = "serial 0 115200"
15SERIAL_CONSOLE = "115200 ttyS0" 15SERIAL_CONSOLE = "115200 ttyS0"
16APPEND += "console=ttyS0,115200 console=tty0" 16APPEND += "console=ttyS0,115200 console=tty0"
17
18MACHINE_EXTRA_RRECOMMENDS += "n450-audio"
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
deleted file mode 100644
index 27904e32..00000000
--- a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Provide a basic init script to enable audio"
2DESCRIPTION = "Set the volume and unmute the Front mixer setting during boot."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r4"
8
9inherit update-rc.d
10
11RDEPENDS = "alsa-utils-amixer"
12
13SRC_URI = "file://n450-audio"
14
15INITSCRIPT_NAME = "n450-audio"
16INITSCRIPT_PARAMS = "defaults 90"
17
18do_install() {
19 install -d ${D}${sysconfdir} \
20 ${D}${sysconfdir}/init.d
21 install -m 0755 ${WORKDIR}/n450-audio ${D}${sysconfdir}/init.d
22 cat ${WORKDIR}/${INITSCRIPT_NAME} | \
23 sed -e 's,/etc,${sysconfdir},g' \
24 -e 's,/usr/sbin,${sbindir},g' \
25 -e 's,/var,${localstatedir},g' \
26 -e 's,/usr/bin,${bindir},g' \
27 -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
28 chmod 755 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
29}
30
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio b/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
deleted file mode 100644
index c5a0044b..00000000
--- a/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
+++ /dev/null
@@ -1,42 +0,0 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: n450 mixer setup
4# Required-Start: $syslog
5# Required-Stop: $syslog
6# Default-Start: 2 3 4 5
7# Default-Stop: 0 1 6
8# Short-Description: Initialize the n450 audio mixer
9# Description: Unmute FRONT and set volume to ~70%.
10### END INIT INFO
11
12# Author: Darren Hart <dvhart@linux.intel.com>
13# Based on /etc/init.d/skeleton
14
15PATH=/sbin:/usr/sbin:/bin:/usr/bin
16DESC="Audio mixer settings"
17NAME=n450-audio
18AMIXER=`which amixer`
19SCRIPTNAME=/etc/init.d/$NAME
20
21# Exit if amixer is not installed
22[ -x "$AMIXER" ] || exit 0
23
24do_start() {
25 # Enable the "Front" simple controls (black phones jack)
26 $AMIXER sset Front 30 on > /dev/null
27}
28
29case "$1" in
30start)
31 echo "$NAME: setting default mixer settings."
32 do_start
33 ;;
34stop)
35 ;;
36*)
37 echo "Usage: $SCRIPTNAME {start|stop}" >&2
38 exit 3
39 ;;
40esac
41
42exit 0