summaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-01-03 15:33:52 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-03 16:46:14 -0800
commit158f88d76685da4e71a21f3788d519dd4b2bb912 (patch)
treea0d07813fdac413ea506a64813521b0e2340fa0c /meta-n450
parentef1c55927c75b4fa0a12796bb21d52dd9fefcfdb (diff)
downloadmeta-intel-158f88d76685da4e71a21f3788d519dd4b2bb912.tar.gz
meta-n450: Add new BSP for BlackSand / n450
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/COPYING.MIT17
-rw-r--r--meta-n450/ReleaseNotes103
-rw-r--r--meta-n450/conf/layer.conf10
-rw-r--r--meta-n450/conf/machine/n450.conf13
-rw-r--r--meta-n450/docs/blacksand.pdfbin0 -> 1415280 bytes
-rw-r--r--meta-n450/recipes-bsp/audiofix/audiofix.bb17
-rw-r--r--meta-n450/recipes-bsp/audiofix/files/n450_audiofix13
-rw-r--r--meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend7
8 files changed, 180 insertions, 0 deletions
diff --git a/meta-n450/COPYING.MIT b/meta-n450/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-n450/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-n450/ReleaseNotes b/meta-n450/ReleaseNotes
new file mode 100644
index 00000000..23ac8153
--- /dev/null
+++ b/meta-n450/ReleaseNotes
@@ -0,0 +1,103 @@
1Poky Laverne Release 4.0
2
3- Features and Updates
4- Known Issues
5
6
7FEATURES AND UPDATES
8====================
9
10- Poky Build System Updates
11 * Saved State / Checksumming
12 * Working prebuilt packages
13 * If a cache of prebuilt packages is present, these should be
14 used to accelerate the build
15 * Task based prebuilts
16 * Meta Directory Update
17 * Debug symbols into sysroot
18 * Builds outside Poky TMPDIR
19 * Can install to a readonly directory
20 * Ability to Build GPL v2 only target images
21 * Swapper integrated to detect host contamination
22- Prelink Tool Integration
23 * Integration of cross prelink tools into Poky
24- Toolchain Update
25 * GCC 4.5.0 now default compiler
26 * EGLIBC is default libc provider
27- New and Updated Recipes
28 * Major update of core recipes
29 * Add additional packages to get initial lsb support
30 * Add QT4 Libraries and demo code
31- Packaging
32 * rootfs creating done with RPM
33 * Use pseudo for setting ownership and permissions
34 * Software package Management now use RPM5 and Zypper
35- Standalone Yocto Linux SDK Generator
36 * Enable other SW development
37 * Output from Poky
38 * Cof a sysroot representing a target system
39 * Includes a standalone cross compiler and cross build tools to isolate the two systems
40- Yocto Linux SDK Generator IDE Plug-ins
41 * Work within IDE using Yocto sysroot environment and cross platform toolchains
42 * Remote user spacke tool suite interaction
43 * Eclipse
44 * Anjuta
45- Yocto Linux SDK Generator remote agent
46 * Runs on a "device"
47 * Manage tasks e.g. deployment, launching remote tools, setup cross debugging session
48- Yocto Linux SDK Generator remote tasks support
49 * Remote deploy support
50 * Remote debug suppport
51 * Remote tools interaction
52- Qemu basic system simulation/emulation
53 * Enhanced with GL passthrough
54 * Support user mode NFS
55- User space tool suite for target device tuning, analyzing and optimizing
56 * OProfile
57 * Powertop
58 * Latencytop
59 * Perf
60 * ftrace/lttng user space
61- Host side clients for tools on target devices and IDE interaction
62 * ProfileUI
63 * Lttv-viewer
64- Updated Documentation
65 * Core Reference Manunal Updated
66 * BSP standard document
67 * Quick Start Guide
68 * FAQs
69
70
71KNOWN ISSUES
72============
73
74See bugzilla.yoctoproject.org
75
76382 - oprofile-server on PPC is built big-endian while oprofile-viewer
77 on host system may built with little-endian, but oprofile-server
78 and oprofile-viewer are not implemented to correctly handle
79 conversion between host byte order and network byte order, so
80 oprofile-server and oprofile-viewer may run into connection issue.
81
82439 - No audio from the Blacksand board Front Channel auido jack.
83 Workaround: run the following cmd: 'amixer sset "Front" 30 on'
84
85467 - Issues building with Fedora 14, this distribution provided a version
86 of make that is not compatible with the Poky build system, the
87 workaround it to build a native version of make via the build system.
88 Users of Fedora 14 will need to do a 'bitbake make-native' before
89 running any other targets.
90
91429 - Building poky from scratch with /opt/poky in your path cause host
92 contamination issues, be sure that /opt/poky is not in your path
93 if building from scratch
94
95160 - The Emenlow Hardware gets stuck in the HW Reboot sequence and needs
96 to be power cycled.
97
98Zypper / RPM Issues
99489/490/491 - Due to some archetectual difference between Zypper and RPM5.0,
100 there are some compatibility issues that prevent zypper from
101 working correctly.
102 Packages can still be managed with the rpm commands.
103
diff --git a/meta-n450/conf/layer.conf b/meta-n450/conf/layer.conf
new file mode 100644
index 00000000..f9cc7fe0
--- /dev/null
+++ b/meta-n450/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "n450"
9BBFILE_PATTERN_n450 = "^${LAYERDIR}/"
10BBFILE_PRIORITY_n450 = "6"
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
new file mode 100644
index 00000000..eda91d9d
--- /dev/null
+++ b/meta-n450/conf/machine/n450.conf
@@ -0,0 +1,13 @@
1#@TYPE: Machine
2#@NAME: n450
3
4#@DESCRIPTION: Machine configuration for Intel 1-N450 based systems
5
6require conf/machine/atom-pc.conf
7
8SYSLINUX_OPTS = "serial 0 115200"
9SERIAL_CONSOLE = "115200 ttyS0"
10APPEND += "console=ttyS0,115200 console=tty0"
11
12PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-stable"
13
diff --git a/meta-n450/docs/blacksand.pdf b/meta-n450/docs/blacksand.pdf
new file mode 100644
index 00000000..971e6df2
--- /dev/null
+++ b/meta-n450/docs/blacksand.pdf
Binary files differ
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb
new file mode 100644
index 00000000..846d59ee
--- /dev/null
+++ b/meta-n450/recipes-bsp/audiofix/audiofix.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Provide a basic init script to enable audio"
2DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r2"
8RDEPENDS = "amixer"
9
10SRC_URI = "file://n450_audiofix"
11
12do_install () {
13 install -d ${D}${sysconfdir}/init.d
14 install -d ${D}${sysconfdir}/rc5.d
15 install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d
16 ln -sf ../init.d/n450_audiofix ${D}/sysconfdir/rc5.d/S91n450_audiofix
17}
diff --git a/meta-n450/recipes-bsp/audiofix/files/n450_audiofix b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
new file mode 100644
index 00000000..9ec04482
--- /dev/null
+++ b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
@@ -0,0 +1,13 @@
1#!/bin/sh
2
3AMIXER=`which amixer`
4
5if [ ! -e $AMIXER ]; then
6 if [ -e /usr/bin/amixer ]; then
7 AMIXER=/usr/bin/amixer
8 else
9 echo "No amixer, so unable to reset Front channel ON"
10 fi
11fi
12
13
diff --git a/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend b/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend
new file mode 100644
index 00000000..3a893f64
--- /dev/null
+++ b/meta-n450/recipes-kernel/linux/linux-wrs_git.bbappend
@@ -0,0 +1,7 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2WRMACHINE_n450 = "atom-pc"
3COMPATIBLE_MACHINE_n450 = "n450"
4
5SRCREV="${AUTOREV}"
6# Functionality flags
7#KERNEL_REVISION_CHECKING ?= "t"