summaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-05-25 12:01:11 -0700
committerDarren Hart <dvhart@linux.intel.com>2011-05-27 09:47:56 -0700
commite94dba8309874a82a570db60223d18b2c723c3a5 (patch)
tree8e353e8ca7aee25c2bdb10b63d1fcb0f6842787a /meta-n450
parentb0f4192e67e3140e41870b967977a2440a415c93 (diff)
downloadmeta-intel-e94dba8309874a82a570db60223d18b2c723c3a5.tar.gz
linux-yocto*: correct FILESEXTRAPATHS assignment in all layers
My previous commit used a self referencing immediate expansion assignment using. This causes a circular reference and build failure, particularly when more than one layer is configured in. Use the _prepend mechanism in conjunction with the immediate expansion assignment operator to accomplish a similar thing without the self referencing. Note: This patch is dependent on changes to oe-core, specifically: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-May/003145.html Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Phill Blundell <pb@pbcl.net> Cc: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/recipes-kernel/linux/linux-yocto-stable_git.bbappend2
-rw-r--r--meta-n450/recipes-kernel/linux/linux-yocto_git.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-n450/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-n450/recipes-kernel/linux/linux-yocto-stable_git.bbappend
index 73a3ee37..18d4999b 100644
--- a/meta-n450/recipes-kernel/linux/linux-yocto-stable_git.bbappend
+++ b/meta-n450/recipes-kernel/linux/linux-yocto-stable_git.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2KMACHINE_n450 = "atom-pc" 2KMACHINE_n450 = "atom-pc"
3COMPATIBLE_MACHINE_n450 = "n450" 3COMPATIBLE_MACHINE_n450 = "n450"
4 4
diff --git a/meta-n450/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-n450/recipes-kernel/linux/linux-yocto_git.bbappend
index 92d666f1..d52a90aa 100644
--- a/meta-n450/recipes-kernel/linux/linux-yocto_git.bbappend
+++ b/meta-n450/recipes-kernel/linux/linux-yocto_git.bbappend
@@ -1,4 +1,4 @@
1FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2KMACHINE_n450 = "yocto/standard/common-pc/atom-pc" 2KMACHINE_n450 = "yocto/standard/common-pc/atom-pc"
3COMPATIBLE_MACHINE_n450 = "n450" 3COMPATIBLE_MACHINE_n450 = "n450"
4 4