diff options
author | Saul Wold <sgw@linux.intel.com> | 2011-01-03 15:33:52 -0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2011-01-03 16:46:14 -0800 |
commit | 158f88d76685da4e71a21f3788d519dd4b2bb912 (patch) | |
tree | a0d07813fdac413ea506a64813521b0e2340fa0c /meta-n450/recipes-bsp/audiofix | |
parent | ef1c55927c75b4fa0a12796bb21d52dd9fefcfdb (diff) | |
download | meta-intel-158f88d76685da4e71a21f3788d519dd4b2bb912.tar.gz |
meta-n450: Add new BSP for BlackSand / n450
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-n450/recipes-bsp/audiofix')
-rw-r--r-- | meta-n450/recipes-bsp/audiofix/audiofix.bb | 17 | ||||
-rw-r--r-- | meta-n450/recipes-bsp/audiofix/files/n450_audiofix | 13 |
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb new file mode 100644 index 00000000..846d59ee --- /dev/null +++ b/meta-n450/recipes-bsp/audiofix/audiofix.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Provide a basic init script to enable audio" | ||
2 | DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on." | ||
3 | SECTION = "base" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=md5=3f40d7994397109285ec7b81fdeb3b58" | ||
6 | |||
7 | PR = "r2" | ||
8 | RDEPENDS = "amixer" | ||
9 | |||
10 | SRC_URI = "file://n450_audiofix" | ||
11 | |||
12 | do_install () { | ||
13 | install -d ${D}${sysconfdir}/init.d | ||
14 | install -d ${D}${sysconfdir}/rc5.d | ||
15 | install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d | ||
16 | ln -sf ../init.d/n450_audiofix ${D}/sysconfdir/rc5.d/S91n450_audiofix | ||
17 | } | ||
diff --git a/meta-n450/recipes-bsp/audiofix/files/n450_audiofix b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix new file mode 100644 index 00000000..9ec04482 --- /dev/null +++ b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix | |||
@@ -0,0 +1,13 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | AMIXER=`which amixer` | ||
4 | |||
5 | if [ ! -e $AMIXER ]; then | ||
6 | if [ -e /usr/bin/amixer ]; then | ||
7 | AMIXER=/usr/bin/amixer | ||
8 | else | ||
9 | echo "No amixer, so unable to reset Front channel ON" | ||
10 | fi | ||
11 | fi | ||
12 | |||
13 | |||