summaryrefslogtreecommitdiffstats
path: root/meta-n450/recipes-bsp/audiofix/audiofix.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-03-11 15:53:11 -0800
committerDarren Hart <dvhart@linux.intel.com>2011-03-12 00:46:41 -0800
commitd1ba49be3052aada2ca8fe8f12787b4fce8a6383 (patch)
tree1691ddc0be4a8df8352b59258856978af1378ab6 /meta-n450/recipes-bsp/audiofix/audiofix.bb
parent4bbfc4f08b0e906ba4182f0ad2baad77a5938db9 (diff)
downloadmeta-intel-d1ba49be3052aada2ca8fe8f12787b4fce8a6383.tar.gz
n450: revamp audio mixer init script
Fixes [YOCTO #798] n450-audiofix suffered from various problems, including not getting installed. This patch adds it via MACHINE_EXTRA_RRECOMMENDS and cleans up the various bugs in the implementation. The structure has been renamed and the comments updated for consistency. This should be considered a stop-gap measure, as something along the lines of oe's alsa-state is a far better solution. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-n450/recipes-bsp/audiofix/audiofix.bb')
-rw-r--r--meta-n450/recipes-bsp/audiofix/audiofix.bb17
1 files changed, 0 insertions, 17 deletions
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb
deleted file mode 100644
index 3b1d2723..00000000
--- a/meta-n450/recipes-bsp/audiofix/audiofix.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "Provide a basic init script to enable audio"
2DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r2"
8RDEPENDS = "alsa-utils-amixer"
9
10SRC_URI = "file://n450_audiofix"
11
12do_install () {
13 install -d ${D}${sysconfdir}/init.d
14 install -d ${D}${sysconfdir}/rc5.d
15 install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d
16 ln -sf ${D}${sysconfdir}/init.d/n450_audiofix ${D}/${sysconfdir}/rc5.d/S91n450_audiofix
17}