diff options
author | Darren Hart <dvhart@linux.intel.com> | 2011-08-17 11:30:10 -0700 |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2011-08-19 14:22:21 -0700 |
commit | 5c41b9b6a245664543e6ddd440d10a0696caaf7b (patch) | |
tree | d142d7fb10447f20ce7ca125c30056f0d670fcc4 /meta-n450/conf/machine/n450.conf | |
parent | fa92a44396b16be74f0de10256b0d42e52cf0bb6 (diff) | |
download | meta-intel-5c41b9b6a245664543e6ddd440d10a0696caaf7b.tar.gz |
n450: decouple from meta-yocto atom-pc machine config
Fixes [YOCTO 1353]
The meta-yocto atom-pc is a more generic BSP than is needed
for the Intel n450. Decouple the n450.conf from the meta-yocto atom-pc.conf.
Add a linux-yocto_3.0.bbappend recipe.
In the process:
o remove MACHINE_FEATURES wifi and add serial
o specify linux-yocto version 3.0
o specify linux-libc-headers-yocto
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-n450/conf/machine/n450.conf')
-rw-r--r-- | meta-n450/conf/machine/n450.conf | 32 |
1 files changed, 28 insertions, 4 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf index f9cf4f2a..888c5d2e 100644 --- a/meta-n450/conf/machine/n450.conf +++ b/meta-n450/conf/machine/n450.conf | |||
@@ -3,13 +3,37 @@ | |||
3 | 3 | ||
4 | #@DESCRIPTION: Machine configuration for Intel 1-N450 based systems | 4 | #@DESCRIPTION: Machine configuration for Intel 1-N450 based systems |
5 | 5 | ||
6 | require conf/machine/atom-pc.conf | 6 | include conf/machine/include/tune-atom.inc |
7 | |||
8 | MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \ | ||
9 | acpi serial" | ||
10 | |||
11 | KERNEL_IMAGETYPE = "bzImage" | ||
12 | |||
13 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | ||
14 | PREFERRED_VERSION_linux-yocto = "3.0+git%" | ||
15 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto" | ||
16 | PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim" | ||
17 | PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri" | ||
18 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite" | ||
19 | PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite" | ||
20 | XSERVER ?= "xserver-xf86-dri-lite \ | ||
21 | xf86-input-mouse \ | ||
22 | xf86-input-keyboard \ | ||
23 | xf86-input-evdev \ | ||
24 | xf86-input-synaptics \ | ||
25 | xf86-video-intel \ | ||
26 | mesa-dri-driver-i915" | ||
7 | 27 | ||
8 | SYSLINUX_OPTS = "serial 0 115200" | 28 | SYSLINUX_OPTS = "serial 0 115200" |
9 | SERIAL_CONSOLE = "115200 ttyS0" | 29 | SERIAL_CONSOLE = "115200 ttyS0" |
10 | APPEND += "console=ttyS0,115200 console=tty0" | 30 | APPEND += "console=ttyS0,115200 console=tty0" |
11 | 31 | ||
12 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto" | 32 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts n450-audio" |
33 | |||
34 | IMAGE_FSTYPES ?= "ext3 cpio.gz live" | ||
35 | |||
36 | GLIBC_ADDONS = "nptl" | ||
37 | GLIBC_EXTRA_OECONF = "--with-tls" | ||
13 | 38 | ||
14 | # Ensure the bsp packages are installed | 39 | ROOTLESS_X = "1" |
15 | MACHINE_EXTRA_RRECOMMENDS += " n450-audio " | ||