summaryrefslogtreecommitdiffstats
path: root/meta-jasperforest/recipes-kernel
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-02-05 19:15:29 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-02-05 20:43:54 -0800
commitc7bf6a327b9b9ebb982324c6ef9f595f7a14f94a (patch)
tree9a3170b066ee4bea9b1926b129c625714be7af63 /meta-jasperforest/recipes-kernel
parentdd0bd45aa410929d0af1be63ab7397fa40148c41 (diff)
downloadmeta-intel-c7bf6a327b9b9ebb982324c6ef9f595f7a14f94a.tar.gz
intel-common: Make using intel-common override opt-in
Currently the intel-core*-common.inc files also include the intel-common-pkgarch.inc, forcing the introduction of the intel-common PACKAGE_ARCH. Coupling this with the addition of the intel-common MACHINE_OVERRIDE, means that even MACHINE_ARCH packages can be influenced by intel-common overrides, which is not desirable. Remove the intel-common-pkgarch.inc from the intel-core*common.inc include files, requiring BSPs wanting to use the intel-common mechanism to explicitly include it. This obviates the need to reset the linux-yocto PACKAGE_ARCH to MACHINE_ARCH. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-jasperforest/recipes-kernel')
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend1
6 files changed, 0 insertions, 6 deletions
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
index f921ae8d..5d6f92fd 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,6 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4 3
5COMPATIBLE_MACHINE_jasperforest = "jasperforest" 4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
6 5
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
index 917853eb..e506bf43 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -1,5 +1,4 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 2COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4KMACHINE_jasperforest = "jasperforest" 3KMACHINE_jasperforest = "jasperforest"
5 4
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
index d14a6ff2..24e63b58 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
@@ -1,6 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4 3
5COMPATIBLE_MACHINE_jasperforest = "jasperforest" 4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
6KMACHINE_jasperforest = "jasperforest" 5KMACHINE_jasperforest = "jasperforest"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 963336d7..45ab6b96 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,6 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4 3
5COMPATIBLE_MACHINE_jasperforest = "jasperforest" 4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
6 5
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 93ceb76e..3182c571 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,6 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4 3
5COMPATIBLE_MACHINE_jasperforest = "jasperforest" 4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
6 5
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 002b7643..459c640f 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,6 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4 3
5COMPATIBLE_MACHINE_jasperforest = "jasperforest" 4COMPATIBLE_MACHINE_jasperforest = "jasperforest"
6 5