summaryrefslogtreecommitdiffstats
path: root/meta-jasperforest/recipes-kernel/linux
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-01-24 13:28:33 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-01-27 16:56:14 -0800
commit8782d90d0df8f63ef7dae2db4bd64069b80738a3 (patch)
treeb57a314d2d19135741e085df99045185f4791151 /meta-jasperforest/recipes-kernel/linux
parent5a2894f2723dcdff6376f4ce7011c879ff54e16d (diff)
downloadmeta-intel-8782d90d0df8f63ef7dae2db4bd64069b80738a3.tar.gz
jasperforest: Set PACKAGE_ARCH to MACHINE_ARCH explicitly
The new intel-common.inc sets the default of the PACKAGE_ARCH for the linux-yocto kernel recipes to DEFAULTTUNE_kernel. Revert the existing recipes to MACHINE_ARCH until they can be removed in favor of a more unified mechanism. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-jasperforest/recipes-kernel/linux')
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend2
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend1
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend2
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend2
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend2
-rw-r--r--meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend2
6 files changed, 11 insertions, 0 deletions
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
index 2f078a9b..f921ae8d 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 5COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4 6
5KMACHINE_jasperforest = "jasperforest" 7KMACHINE_jasperforest = "jasperforest"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
index e506bf43..917853eb 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -1,4 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
2COMPATIBLE_MACHINE_jasperforest = "jasperforest" 3COMPATIBLE_MACHINE_jasperforest = "jasperforest"
3KMACHINE_jasperforest = "jasperforest" 4KMACHINE_jasperforest = "jasperforest"
4 5
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
index e586a6e6..d14a6ff2 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 5COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4KMACHINE_jasperforest = "jasperforest" 6KMACHINE_jasperforest = "jasperforest"
5 7
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 00842334..963336d7 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 5COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4 6
5KMACHINE_jasperforest = "jasperforest" 7KMACHINE_jasperforest = "jasperforest"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 84d36df5..93ceb76e 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 5COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4 6
5KMACHINE_jasperforest = "jasperforest" 7KMACHINE_jasperforest = "jasperforest"
diff --git a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
index c79f4fe5..002b7643 100644
--- a/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-jasperforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,5 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_jasperforest = "${MACHINE_ARCH}"
4
3COMPATIBLE_MACHINE_jasperforest = "jasperforest" 5COMPATIBLE_MACHINE_jasperforest = "jasperforest"
4 6
5KMACHINE_jasperforest = "jasperforest" 7KMACHINE_jasperforest = "jasperforest"