summaryrefslogtreecommitdiffstats
path: root/meta-isg
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-07-10 21:23:53 +0800
committerSaul Wold <sgw@linux.intel.com>2015-07-10 08:17:08 -0700
commiteeb5db0dc19b0ebf9e9afa813c5cd79a6ffec01d (patch)
treede46d61bcd6f7a566ac190d84f9333f845331bae /meta-isg
parentde7785e1cb4f33ad2087a7da71def9401a6a284b (diff)
downloadmeta-intel-eeb5db0dc19b0ebf9e9afa813c5cd79a6ffec01d.tar.gz
meta-isg: dpdk v2.0.0: initial DPDK v2.0.0 enabling recipe
This patch makes reference to early dpdk meta-data implementation and extends it to support DPDK v2.0.0. Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
new file mode 100644
index 00000000..cb158b92
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
@@ -0,0 +1,29 @@
1include dpdk.inc
2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934"
12SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f"
13
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic"
16
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"