summaryrefslogtreecommitdiffstats
path: root/meta-isg
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-07-28 16:05:08 +0800
committerDarren Hart <dvhart@linux.intel.com>2015-07-29 11:28:43 -0700
commit76d81da78421b48cea47d7090855173f87a43a99 (patch)
treec4ecd3ae728b3d1c1855b300299717d8f2fdc49d /meta-isg
parentb88b9629f7c02a6bf27d96577cb725077c711c50 (diff)
downloadmeta-intel-76d81da78421b48cea47d7090855173f87a43a99.tar.gz
meta-isg: dpdk: tidy up dpdk.inc & removed unnecessary patches
This patch tidy up dpdk.inc and removing unnecessary patches. Integrating common recipe from dpdk_1.8.0.bb and dpdk_2.0.0.bb. Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-isg')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc20
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch48
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch43
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch50
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb22
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb22
6 files changed, 20 insertions, 185 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index 85b88fa0..59946cfb 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -3,6 +3,26 @@ HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD & LGPLv2 & GPLv2" 3LICENSE = "BSD & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe"
5 5
6SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
10 "
11
12# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
13# fuse is in meta-filesystems and qat is not yet upstreamed.
14# So adding mechanism to explicitly disable the use of fuse and qat.
15# To enable, uncomment the below line or include in .bbappend.
16# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
17
18PACKAGECONFIG[dpdk_qat] = ",,qat"
19PACKAGECONFIG[vhost] = ",,fuse"
20PACKAGECONFIG[libvirt] = ",,libvirt"
21
22export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
23export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
24export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
25
6RDEPENDS_${PN} += "python-subprocess" 26RDEPENDS_${PN} += "python-subprocess"
7DEPENDS = "virtual/kernel" 27DEPENDS = "virtual/kernel"
8do_configure[depends] += "virtual/kernel:do_shared_workdir" 28do_configure[depends] += "virtual/kernel:do_shared_workdir"
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
deleted file mode 100644
index 979541e9..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 6eaf6b1a61321acb824f9672c12d0e30a2110f52 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Mon, 16 Mar 2015 11:10:43 +0800
4Subject: [PATCH] DPDK: defconfig: add selectable RTE_MACHINE option
5
6In order to make sure that DPDK build environment config can handle the
7package being built on different build machine for different target machine
8which will have different x86 architecture intrinsics than the build machine,
9we introduce DPDK_TARGET_MACH to be tunable from dpdk recipe. The machine
10type can be under mk/machine folder.
11
12Upstream-Status: Inappropriate [configuration]
13
14Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
15---
16 config/defconfig_i686-native-linuxapp-gcc | 2 +-
17 config/defconfig_x86_64-native-linuxapp-gcc | 2 +-
18 2 files changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/config/defconfig_i686-native-linuxapp-gcc b/config/defconfig_i686-native-linuxapp-gcc
21index a90de9b..c9a74a5 100644
22--- a/config/defconfig_i686-native-linuxapp-gcc
23+++ b/config/defconfig_i686-native-linuxapp-gcc
24@@ -32,7 +32,7 @@
25
26 #include "common_linuxapp"
27
28-CONFIG_RTE_MACHINE="native"
29+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
30
31 CONFIG_RTE_ARCH="i686"
32 CONFIG_RTE_ARCH_I686=y
33diff --git a/config/defconfig_x86_64-native-linuxapp-gcc b/config/defconfig_x86_64-native-linuxapp-gcc
34index 60baf5b..0e4802d 100644
35--- a/config/defconfig_x86_64-native-linuxapp-gcc
36+++ b/config/defconfig_x86_64-native-linuxapp-gcc
37@@ -32,7 +32,7 @@
38
39 #include "common_linuxapp"
40
41-CONFIG_RTE_MACHINE="native"
42+CONFIG_RTE_MACHINE=$(DPDK_TARGET_MACH)
43
44 CONFIG_RTE_ARCH="x86_64"
45 CONFIG_RTE_ARCH_X86_64=y
46--
471.7.9.5
48
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
deleted file mode 100644
index e8ded8d0..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From c1a59d62f2aa7656060d8ebcc8e45e852d931ff1 Mon Sep 17 00:00:00 2001
2From: Ong Boon Leong <boon.leong.ong@intel.com>
3Date: Tue, 17 Feb 2015 00:23:12 +0800
4Subject: [PATCH] dpdk: enable VHOST build config in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com>
12---
13 config/common_linuxapp | 6 +++---
14 1 file changed, 3 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 2f9643b..67f5edb 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -361,9 +361,9 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 #
22 CONFIG_RTE_LIBRTE_KNI=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32@@ -372,7 +372,7 @@ CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
33 # fuse-devel is needed to run vhost.
34 # fuse-devel enables user space char driver development
35 #
36-CONFIG_RTE_LIBRTE_VHOST=n
37+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
38 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
39
40 #
41--
421.7.9.5
43
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
deleted file mode 100644
index 45ce5e05..00000000
--- a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From 3d3c03d947394696565b3bb7bed8c900de057a28 Mon Sep 17 00:00:00 2001
2From: WU CHIA CHUAN <chia.chuan.wu@intel.com>
3Date: Thu, 2 Jul 2015 15:59:18 +0800
4Subject: [PATCH] dpdk enable VHOST and ip_fragmentation in common_linuxapp config
5
6Introduce CONFIG_VHOST_ENABLED for package config selection purpose in
7building vhost feature.
8
9Upstream-Status: Inappropriate [configuration]
10
11Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com>
12---
13 config/common_linuxapp | 11 ++++++++---
14 1 file changed, 8 insertions(+), 3 deletions(-)
15
16diff --git a/config/common_linuxapp b/config/common_linuxapp
17index 0b25f34..000f950 100644
18--- a/config/common_linuxapp
19+++ b/config/common_linuxapp
20@@ -406,19 +406,24 @@ CONFIG_RTE_LIBRTE_PIPELINE=y
21 CONFIG_RTE_LIBRTE_KNI=y
22 CONFIG_RTE_KNI_PREEMPT_DEFAULT=y
23 CONFIG_RTE_KNI_KO_DEBUG=n
24-CONFIG_RTE_KNI_VHOST=n
25+CONFIG_RTE_KNI_VHOST=$(CONFIG_VHOST_ENABLED)
26 CONFIG_RTE_KNI_VHOST_MAX_CACHE_SIZE=1024
27-CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=n
28+CONFIG_RTE_KNI_VHOST_VNET_HDR_EN=$(CONFIG_VHOST_ENABLED)
29 CONFIG_RTE_KNI_VHOST_DEBUG_RX=n
30 CONFIG_RTE_KNI_VHOST_DEBUG_TX=n
31
32 #
33+# Compile ip_fragmentation
34+#
35+CONFIG_RTE_IP_FRAG=y
36+
37+#
38 # Compile vhost library
39 # fuse-devel is needed to run vhost-cuse.
40 # fuse-devel enables user space char driver development
41 # vhost-user is turned on by default.
42 #
43-CONFIG_RTE_LIBRTE_VHOST=n
44+CONFIG_RTE_LIBRTE_VHOST=$(CONFIG_VHOST_ENABLED)
45 CONFIG_RTE_LIBRTE_VHOST_USER=y
46 CONFIG_RTE_LIBRTE_VHOST_DEBUG=n
47
48--
491.7.9.5
50
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
index 5265a9cf..b1a3aea5 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_1.8.0.bb
@@ -1,33 +1,11 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-1.8.0-dpdk-enable-build-config-VHOST-in-common_linuxapp-config.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22" 3SRC_URI[dpdk.md5sum] = "11ad8785aaa869cc87265bcb8d828f22"
12SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939" 4SRC_URI[dpdk.sha256sum] = "9f5386830bd999355182e20408f3fc2cfa0802a4497fdded8d43202feede1939"
13 5
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 6export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 7export ARCHDIR = "generic"
16 8
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
30
31do_install_append () { 9do_install_append () {
32 10
33 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp 11 install -m 0755 -d ${D}/${INSTALL_PATH}/${RTE_TARGET}/hostapp
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
index cb158b92..0e9350b1 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
@@ -1,29 +1,7 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934" 3SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934"
12SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f" 4SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f"
13 5
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 6export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 7export ARCHDIR = "generic"
16
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"