summaryrefslogtreecommitdiffstats
path: root/meta-isg
diff options
context:
space:
mode:
authorAnuj Mittal <anujx.mittal@intel.com>2015-08-27 18:15:15 +0800
committerSaul Wold <sgw@linux.intel.com>2015-08-27 19:14:43 -0700
commit4c0f5f8975671e83df5b243e71ef92654ac344c8 (patch)
treeef6b10d1e588494e4d493607fc4b4e17252d567a /meta-isg
parent7559504bf2186f78c2775998ff4fd15f3cc9010b (diff)
downloadmeta-intel-4c0f5f8975671e83df5b243e71ef92654ac344c8.tar.gz
meta-isg: enable dpdk v2.1.0 for grantley
This adds the recipe for dpdk v2.1.0 for grantley platforms based on common intel-corei7-64 BSP. Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch31
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb16
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
new file mode 100644
index 00000000..cd517052
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk/dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch
@@ -0,0 +1,31 @@
1From a424a79b1422f1877de3ee7aee6f781aeacc3630 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Tue, 18 Aug 2015 12:36:02 +0800
4Subject: [PATCH] examples: add config variable to enable/disable dpdk_qat
5
6Upstream-Status: Inappropriate [configuration]
7
8Add CONFIG_EXAMPLE_DPDK_QAT to control compilation of dpdk_qat
9example by PACKAGECONFIG
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 examples/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/examples/Makefile b/examples/Makefile
17index b4eddbd..1bc14b0 100644
18--- a/examples/Makefile
19+++ b/examples/Makefile
20@@ -41,7 +41,7 @@ DIRS-$(CONFIG_RTE_LIBRTE_PMD_BOND) += bond
21 DIRS-y += cmdline
22 DIRS-$(CONFIG_RTE_LIBRTE_DISTRIBUTOR) += distributor
23 ifneq ($(ICP_ROOT),)
24-DIRS-y += dpdk_qat
25+DIRS-$(CONFIG_EXAMPLE_DPDK_QAT) += dpdk_qat
26 endif
27 DIRS-y += exception_path
28 DIRS-y += helloworld
29--
301.7.9.5
31
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
new file mode 100644
index 00000000..7a7af6fe
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.1.0.bb
@@ -0,0 +1,16 @@
1include dpdk.inc
2
3SRC_URI += "\
4 file://dpdk-2.1.0-add-config-variable-to-enable-disable-dpdk_qat.patch \
5 file://dpdk-2.0.0-dpdk-enable-ip_fragmentation-in-common_linuxapp.patch \
6 "
7
8SRC_URI[dpdk.md5sum] = "205a0d12bfd6eb717d57506272f43519"
9SRC_URI[dpdk.sha256sum] = "f7b322867a45f99afd9c8fbacdc56e1621676f9ca0f046656ec85eb6a99a3440"
10
11export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
12export ARCHDIR = "generic"
13
14do_configure_prepend () {
15 sed -e "s#CONFIG_RTE_LIBRTE_POWER=y#CONFIG_RTE_LIBRTE_POWER=${CONFIG_EXAMPLE_VM_POWER_MANAGER}#" -i ${S}/config/common_linuxapp
16}