summaryrefslogtreecommitdiffstats
path: root/meta-isg/meta-valleyisland
diff options
context:
space:
mode:
authorChan Wei Sern <wei.sern.chan@intel.com>2014-05-23 23:17:19 +0800
committerTom Zanussi <tom.zanussi@linux.intel.com>2014-05-24 18:07:29 -0500
commit50023dc8955390460bd7dd540bf9688dc7050b2d (patch)
tree8f7201b0763157eba08b0cc570e02224bb4b2279 /meta-isg/meta-valleyisland
parent0c80a8a3b39c5366499af19060bcf8fd23643219 (diff)
downloadmeta-intel-50023dc8955390460bd7dd540bf9688dc7050b2d.tar.gz
meta-valleyisland: Add linux-yocto 3.10 recipe
Added linux-yocto 3.10 due to it cannot be shared with common intel recipe kernel. The reason cannot be shared as for valleyisland case has additional feature that is still pending to pull into LTS/LTSI and hence it cannot be merged into "standard/base". For this particular reason, a feature branch of "valleyisland-io-1.0" is introduced to include additional feature. However in order to make it more align with intel common recipe kernel,machine branch is pointing to "standard/base" and SRCREV for meta remains closest as possible. Signed-off-by: Chan Wei Sern <wei.sern.chan@intel.com> Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Acked-By: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'meta-isg/meta-valleyisland')
-rw-r--r--meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 00000000..34e28c1e
--- /dev/null
+++ b/meta-isg/meta-valleyisland/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,35 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3#############################
4# MACHINE = valleyisland-32 #
5#############################
6COMPATIBLE_MACHINE_valleyisland-32 = "valleyisland-32"
7KMACHINE_valleyisland-32 = "valleyisland-32"
8KBRANCH_valleyisland-32 = "standard/base"
9KERNEL_FEATURES_valleyisland-32 = " features/valleyisland-io/valleyisland-io \
10 features/valleyisland-io/valleyisland-io-pci.scc"
11
12LINUX_VERSION_valleyisland-32 = "3.10.40"
13SRCREV_machine_valleyisland-32 = "f53a6114b3a6e8c03ca4752de829887015f4c942"
14SRCREV_meta_valleyisland-32 = "90edb289dccfe838d4e364e1a5815447a6642b98"
15SRCREV_valleyisland-io_valleyisland-32 = "8ea4fb625f2654bbdd5dfcb9db67328d21ebe504"
16
17SRC_URI_valleyisland-32 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io"
18
19#############################
20# MACHINE = valleyisland-64 #
21#############################
22COMPATIBLE_MACHINE_valleyisland-64 = "valleyisland-64"
23KMACHINE_valleyisland-64 = "valleyisland"
24KBRANCH_valleyisland-64 = "standard/base"
25KERNEL_FEATURES_valleyisland-64 = " features/valleyisland-io/valleyisland-io \
26 features/valleyisland-io/valleyisland-io-pci.scc"
27
28LINUX_VERSION_valleyisland-64 = "3.10.40"
29SRCREV_machine_valleyisland-64 = "f53a6114b3a6e8c03ca4752de829887015f4c942"
30SRCREV_meta_valleyisland-64 = "90edb289dccfe838d4e364e1a5815447a6642b98"
31SRCREV_valleyisland-io_valleyisland-64 = "8ea4fb625f2654bbdd5dfcb9db67328d21ebe504"
32
33SRC_URI_valleyisland-64 = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},valleyisland-io-1.0;name=machine,meta,valleyisland-io"
34
35module_autoload_i2c-dev = "i2c-dev"