summaryrefslogtreecommitdiffstats
path: root/meta-isg/common
diff options
context:
space:
mode:
authorAnuj Mittal <anujx.mittal@intel.com>2015-09-18 15:40:06 +0800
committerSaul Wold <sgw@linux.intel.com>2015-09-21 09:14:59 -0700
commit88a5f5857d56e4a8952a7cd7d215178a78161871 (patch)
tree8bbca1899aa7fbb241e7a82e3816f385ab6aa1fd /meta-isg/common
parent1201a576c9bcdab3bfcf87efeb2184f0025ae53e (diff)
downloadmeta-intel-88a5f5857d56e4a8952a7cd7d215178a78161871.tar.gz
meta-isg: qat: fix strict_str* compile errors
Defines strict_str* have become obsolete and removed entirely starting from kernel v3.18. This results in errors like: error: implicit declaration of function 'strict_strtoull' [-Werror=implicit-function-declaration] Replace strict_strtoull with kstrtoull to ensure qat 2.3.0-34 compiles. Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg/common')
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch40
-rw-r--r--meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch
new file mode 100644
index 00000000..dee1f71a
--- /dev/null
+++ b/meta-isg/common/recipes-extended/qat/qat16/qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch
@@ -0,0 +1,40 @@
1From 4ef0e0124f73b3bc24b2f2a772d83176aaa9fb3f Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anujx.mittal@intel.com>
3Date: Tue, 8 Sep 2015 11:53:36 +0800
4Subject: [PATCH] qat: replace strict_strtoull with kstrtoull
5
6Upstream-Status: Backport
7
8strict_strtoull() has been removed starting kernel v3.18.
9Hence, replace the usage with kstrtoull().
10
11Signed-off-by: Anuj Mittal <anujx.mittal@intel.com>
12---
13 .../uclo/include/linux/uclo_platform.h | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/quickassist/utilities/downloader/Target_CoreLibs/uclo/include/linux/uclo_platform.h b/quickassist/utilities/downloader/Target_CoreLibs/uclo/include/linux/uclo_platform.h
17index a4bf903..ee3e2d8 100755
18--- a/quickassist/utilities/downloader/Target_CoreLibs/uclo/include/linux/uclo_platform.h
19+++ b/quickassist/utilities/downloader/Target_CoreLibs/uclo/include/linux/uclo_platform.h
20@@ -116,6 +116,9 @@
21 /* 32-bit/64-bit 2.6.29 kernel does not export simple_strtoll */
22 #define STR_TO_32(str, base, num, endPtr) {*(num) = (int)simple_strtol((str), &(endPtr), (base));}
23
24+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,18,0)
25+#define STR_TO_64(str, base, num, endPtr) {endPtr=NULL; if (kstrtoull((str), (base), (num))) printk("Error strtoull convert %s\n", str); }
26+#else
27 #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,38)
28 #define STR_TO_64(str, base, num, endPtr) {endPtr=NULL; if (strict_strtoull((str), (base), (num))) printk("Error strtoull convert %s\n", str); }
29 #else
30@@ -133,6 +136,7 @@
31 } while(0)
32 #endif
33 #endif
34+#endif
35
36 int aToi(const char *pStr);
37
38--
391.7.9.5
40
diff --git a/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb b/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
index 293323dd..d6e9af40 100644
--- a/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
+++ b/meta-isg/common/recipes-extended/qat/qat16_2.3.0-34.bb
@@ -1,6 +1,7 @@
1include qat16.inc 1include qat16.inc
2 2
3SRC_URI += "file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \ 3SRC_URI += "file://qat16_2.3.0-34-qat-add-install-target-to-makefiles.patch \
4 file://qat16_2.3.0-34-qat-replace-strict_strtoull-with-kstrtoull.patch \
4 " 5 "
5 6
6SRC_URI[qat.md5sum] = "9614bf598bc8e7eedc8adb6d29109033" 7SRC_URI[qat.md5sum] = "9614bf598bc8e7eedc8adb6d29109033"