summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-07-28 16:05:08 +0800
committerDarren Hart <dvhart@linux.intel.com>2015-07-29 11:28:43 -0700
commit76d81da78421b48cea47d7090855173f87a43a99 (patch)
treec4ecd3ae728b3d1c1855b300299717d8f2fdc49d /meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
parentb88b9629f7c02a6bf27d96577cb725077c711c50 (diff)
downloadmeta-intel-76d81da78421b48cea47d7090855173f87a43a99.tar.gz
meta-isg: dpdk: tidy up dpdk.inc & removed unnecessary patches
This patch tidy up dpdk.inc and removing unnecessary patches. Integrating common recipe from dpdk_1.8.0.bb and dpdk_2.0.0.bb. Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb22
1 files changed, 0 insertions, 22 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
index cb158b92..0e9350b1 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_2.0.0.bb
@@ -1,29 +1,7 @@
1include dpdk.inc 1include dpdk.inc
2 2
3SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
4 file://dpdk-2.0.0-dpdk-enable-VHOST-and-ip_fragmentation-in-common_linuxapp.patch \
5 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
6 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
7 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
8 file://dpdk-1.8.0-and-2.0.0-dpdk-defconfig-select-RTE_MACHINE-type.patch \
9 "
10
11SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934" 3SRC_URI[dpdk.md5sum] = "e9e7935c9eec920841ad373949514934"
12SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f" 4SRC_URI[dpdk.sha256sum] = "643789a3be5ba44dd84d6b248cdf5471b260f8736dada177dadf076aebfbff3f"
13 5
14export EXAMPLES_BUILD_DIR = "${RTE_TARGET}" 6export EXAMPLES_BUILD_DIR = "${RTE_TARGET}"
15export ARCHDIR = "generic" 7export ARCHDIR = "generic"
16
17# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
18# fuse is in meta-filesystems and qat is not yet upstreamed.
19# So adding mechanism to explicitly disable the use of fuse and qat.
20# To enable, uncomment the below line or include in .bbappend.
21# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
22
23PACKAGECONFIG[dpdk_qat] = ",,qat"
24PACKAGECONFIG[vhost] = ",,fuse"
25PACKAGECONFIG[libvirt] = ",,libvirt"
26
27export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
28export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
29export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"