summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb
diff options
context:
space:
mode:
authorvenkatasubramanian pattu <venkatasubramanianx.pattu@intel.com>2015-05-08 12:08:50 +0800
committerSaul Wold <sgw@linux.intel.com>2015-06-02 12:35:00 -0700
commit829a48548fe545a6f9cefbf043e4440fc6c746bc (patch)
treee24f8fa00e77c56bcfb15bcc567d138b6549cc0d /meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb
parent578494c0c4715bb8d24972fa52850e89c36410a1 (diff)
downloadmeta-intel-829a48548fe545a6f9cefbf043e4440fc6c746bc.tar.gz
meta-isg: Intel DPDK v1.6 recipe under recipes-extended
This is an initial version of Intel Data Plane Development Kits (DPDK) recipe support. This recipe is targeting on Intel DPDK v1.6.0r2. Intel DPDK is needed for several IoTG maintained BSPs such as Crystal Forest & Highland Forest, Mohon Peak. Therefore, we place DPDK recipe under meta-isg/common/recipes-extended folder. This recipe is cherry-picked from branch dizzy and the commit ID: c249763d3cb92bd06742b7986f08cf844ddb1d51:meta-intel/common: Initial Intel DPDK recipe under recipes-extended This commit is removed in latest dizzy (1.7) due to build failure. DPDK v1.7 & v1.6 are validated on Linux kernel v3.10 and not supported on Linux kernel v3.17. Therefore, this recipe is intended to be supported only on Linux kernel v3.10 for all CID related platforms like Crystal Forest and Highland Forest. Signed-off-by: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb b/meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb
new file mode 100644
index 00000000..a507d4e9
--- /dev/null
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk_1.6.0r2.bb
@@ -0,0 +1,44 @@
1include dpdk.inc
2
3
4SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
5 file://dpdk-1.6.0r2-examples-qos_sched-fix-makefile.patch \
6 file://dpdk-1.6.0r2-app-test-fix-build-switches-to-enable-cmdline-tests.patch \
7 file://dpdk-1.6.0r2-eal-fix-option-base-virtaddr.patch \
8 "
9
10
11SRC_URI[dpdk.md5sum] = "f406d027320fc8e724bff20db5397cbb"
12SRC_URI[dpdk.sha256sum] = "e72fdebcf8a899fc58e60c9b6493b7457576eece60b08dea6aee96c9087df4b2"
13
14export EXAMPLES_BUILD_DIR = "build"
15
16do_compile_append () {
17
18 ###################################################################
19 ### Compilation for examples
20 ### Skip dpdk_qat due to it has dependency with qat source code
21 ### Skip vhost due to it has dependency to fuse libraries
22 ### Skip vhost_xen due to it has dependency to xen libraries
23 ###################################################################
24 for app in ${S}/examples/*
25 do
26
27 [ `basename ${app}` = "dpdk_qat" -o `basename ${app}` = "vhost" -o `basename ${app}` = "vhost_xen" ] && continue;
28
29 cd ${app}
30
31 ###############################################################
32 # netmap_compat is putting the binary in a directory path
33 # which is different from rest of the example apps, so this
34 # special case is handled here to avoid installation failure
35 # with dpdk-1.6.0
36 ###############################################################
37 if [ `basename ${app}` == "netmap_compat" ]; then
38 oe_runmake CROSS="${TARGET_PREFIX}" O="${app}/bridge/${EXAMPLES_BUILD_DIR}/"
39 else
40 oe_runmake CROSS="${TARGET_PREFIX}"
41 fi
42 done
43
44}