summaryrefslogtreecommitdiffstats
path: root/meta-isg/common/recipes-extended/dpdk/dpdk.inc
diff options
context:
space:
mode:
authorWU CHIA CHUAN <chia.chuan.wu@intel.com>2015-07-28 16:05:08 +0800
committerDarren Hart <dvhart@linux.intel.com>2015-07-29 11:28:43 -0700
commit76d81da78421b48cea47d7090855173f87a43a99 (patch)
treec4ecd3ae728b3d1c1855b300299717d8f2fdc49d /meta-isg/common/recipes-extended/dpdk/dpdk.inc
parentb88b9629f7c02a6bf27d96577cb725077c711c50 (diff)
downloadmeta-intel-76d81da78421b48cea47d7090855173f87a43a99.tar.gz
meta-isg: dpdk: tidy up dpdk.inc & removed unnecessary patches
This patch tidy up dpdk.inc and removing unnecessary patches. Integrating common recipe from dpdk_1.8.0.bb and dpdk_2.0.0.bb. Signed-off-by: Ong Boon Leong <boon.leong.ong@intel.com> Signed-off-by: WU CHIA CHUAN <chia.chuan.wu@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-isg/common/recipes-extended/dpdk/dpdk.inc')
-rw-r--r--meta-isg/common/recipes-extended/dpdk/dpdk.inc20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-isg/common/recipes-extended/dpdk/dpdk.inc b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
index 85b88fa0..59946cfb 100644
--- a/meta-isg/common/recipes-extended/dpdk/dpdk.inc
+++ b/meta-isg/common/recipes-extended/dpdk/dpdk.inc
@@ -3,6 +3,26 @@ HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD & LGPLv2 & GPLv2" 3LICENSE = "BSD & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe" 4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe"
5 5
6SRC_URI = "http://dpdk.org/browse/dpdk/snapshot/dpdk-${PV}.tar.gz;name=dpdk \
7 file://dpdk-1.8.0-and-2.0.0-examples-add-config-variable-to-enable-disable-dpdk.patch \
8 file://dpdk-1.8.0-and-2.0.0-add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
9 file://dpdk-1.8.0-and-2.0.0-add-sysroot-option-within-app-makefile.patch \
10 "
11
12# dpdk example apps dpdk_qat and vhost have dependancy on fuse and qat.
13# fuse is in meta-filesystems and qat is not yet upstreamed.
14# So adding mechanism to explicitly disable the use of fuse and qat.
15# To enable, uncomment the below line or include in .bbappend.
16# PACKAGECONFIG ?= " dpdk_qat vhost libvirt"
17
18PACKAGECONFIG[dpdk_qat] = ",,qat"
19PACKAGECONFIG[vhost] = ",,fuse"
20PACKAGECONFIG[libvirt] = ",,libvirt"
21
22export CONFIG_EXAMPLE_DPDK_QAT = "${@base_contains('PACKAGECONFIG', 'dpdk_qat', 'y', 'n', d)}"
23export CONFIG_EXAMPLE_VM_POWER_MANAGER = "${@base_contains('PACKAGECONFIG', 'libvirt', 'y', 'n', d)}"
24export CONFIG_VHOST_ENABLED = "${@base_contains('PACKAGECONFIG', 'vhost', 'y', 'n', d)}"
25
6RDEPENDS_${PN} += "python-subprocess" 26RDEPENDS_${PN} += "python-subprocess"
7DEPENDS = "virtual/kernel" 27DEPENDS = "virtual/kernel"
8do_configure[depends] += "virtual/kernel:do_shared_workdir" 28do_configure[depends] += "virtual/kernel:do_shared_workdir"