summaryrefslogtreecommitdiffstats
path: root/meta-fri2
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2013-12-16 10:02:01 -0800
committerDarren Hart <dvhart@linux.intel.com>2013-12-16 10:55:54 -0800
commita665015a6a95be732eeee8f7a915fcf0e030c112 (patch)
tree6f65245609b43f8ff36d7364f6eb7db8f5c5ebd1 /meta-fri2
parenta649e92498d234f2d0d52f3da5a85bdc87296c23 (diff)
downloadmeta-intel-a665015a6a95be732eeee8f7a915fcf0e030c112.tar.gz
grub-efi: Rename and update grub-efi for recent oe-core changes
OE-Core has changed the grub-efi implementation, splitting out grub-efi-native and moving the do_mkimage task to do_deploy. Rename and update this bbappend accordingly. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Acked-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'meta-fri2')
-rw-r--r--meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend (renamed from meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend)10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend b/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
index c6904ef0..f6105711 100644
--- a/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
+++ b/meta-fri2/recipes-bsp/grub/grub-efi_2.00.bbappend
@@ -2,10 +2,12 @@
2# before launching the grub.efi payload. Ensure GRUB has keyboard control by 2# before launching the grub.efi payload. Ensure GRUB has keyboard control by
3# building in the usb, usb_keyboard, and ohci modules. 3# building in the usb, usb_keyboard, and ohci modules.
4 4
5do_mkimage() { 5do_deploy() {
6 ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \ 6 # Search for the grub.cfg on the local boot media by using the
7 # built in cfg file provided via this recipe
8 grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
7 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \ 9 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
8 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop \ 10 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search \
9 usb usb_keyboard ohci 11 usb usb_keyboard ohci
12 install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
10} 13}
11