summaryrefslogtreecommitdiffstats
path: root/meta-fri2
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-10-23 21:27:46 -0700
committerDarren Hart <dvhart@linux.intel.com>2012-10-24 13:16:00 -0700
commit62aa4ca25a943c864838b2910c5b506cca0c9323 (patch)
tree124b1629bbf18439a87b4dcee3f4beb1bddb7caa /meta-fri2
parente703492712529398b2c44ea233ce6620864c28a5 (diff)
downloadmeta-intel-62aa4ca25a943c864838b2910c5b506cca0c9323.tar.gz
fri2: Add grub-efi workaround for USB keyboard initialization
The Fastboot firmware will sometimes fail to init the USB keyboard when connected directly in 1.0 mode (works fine through a 2.0 hub). By adding the USB modules to the grub-efi build, we can ensure the keyboard will be available in the grub menu at the expense of about a second in boot time. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Acked-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-fri2')
-rw-r--r--meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend b/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
new file mode 100644
index 00000000..c6904ef0
--- /dev/null
+++ b/meta-fri2/recipes-bsp/grub/grub-efi-native_2.00.bbappend
@@ -0,0 +1,11 @@
1# The Intel provided Fast Boot Firmware may not initialize the USB keyboard
2# before launching the grub.efi payload. Ensure GRUB has keyboard control by
3# building in the usb, usb_keyboard, and ohci modules.
4
5do_mkimage() {
6 ./grub-mkimage -p /EFI/BOOT -d ./grub-core/ \
7 -O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
8 boot linux ext2 fat serial part_msdos part_gpt normal efi_gop \
9 usb usb_keyboard ohci
10}
11