diff options
author | Darren Hart <dvhart@linux.intel.com> | 2014-06-26 14:22:10 +0000 |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2014-06-26 14:22:10 +0000 |
commit | 05dd98cf5c117a8bdd566d36d20a84fff20e8cc3 (patch) | |
tree | eedb3499fcc3881c9c3bd8275e8f0269fbc3b3cd /meta-fri2/recipes-kernel | |
parent | 76f529881208811e314dba1478cc3a70abf3160f (diff) | |
download | meta-intel-05dd98cf5c117a8bdd566d36d20a84fff20e8cc3.tar.gz |
linux-yocto: Make KERNEL_MODULE_AUTOLOAD machine specific
BSP linux-yocto bbappend files should make all variable updates with
machine-specific overrides. As it stands, building qemux86 with
meta-intel in BBLAYERS will add uio and iwlwifi to
KERNEL_MODULES_AUTOLOAD. This corrects that.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-fri2/recipes-kernel')
-rw-r--r-- | meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend | 3 | ||||
-rw-r--r-- | meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend | 3 |
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend index 7aaf53af..e57449f9 100644 --- a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend +++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend | |||
@@ -12,4 +12,5 @@ KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2" | |||
12 | SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" | 12 | SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" |
13 | #SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" | 13 | #SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" |
14 | 14 | ||
15 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 15 | KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" |
16 | KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" | ||
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend index 14bb81a0..a4732f21 100644 --- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend +++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend | |||
@@ -18,4 +18,5 @@ LINUX_VERSION_fri2-noemgd = "3.10.38" | |||
18 | SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" | 18 | SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" |
19 | SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" | 19 | SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" |
20 | 20 | ||
21 | KERNEL_MODULE_AUTOLOAD += "iwlwifi" | 21 | KERNEL_MODULE_AUTOLOAD_fri2 += "iwlwifi" |
22 | KERNEL_MODULE_AUTOLOAD_fri2-noemgd += "iwlwifi" | ||