summaryrefslogtreecommitdiffstats
path: root/meta-fri2/recipes-kernel/linux
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-06-17 17:47:44 -0700
committerTom Zanussi <tom.zanussi@intel.com>2014-06-23 09:47:47 -0500
commitbf97ece14e1444e3898798599a4299ad1c7556c6 (patch)
tree55a3d8408685d9339c87e1ea98b09395cbd474ad /meta-fri2/recipes-kernel/linux
parent6aa0c6a6a75f6a4c2fda8e59be1212464307c69a (diff)
downloadmeta-intel-bf97ece14e1444e3898798599a4299ad1c7556c6.tar.gz
linux-yocto recipes: fix use of module_autoload_* vars
oecore/poky layer changed, needing replacement of all the module_autoload_* recipe variables by the KERNEL_MODULE_AUTOLOAD variable. This fixes these kind of buildtime errors coming from the meta-intel layer: ERROR: KERNEL_MODULE_AUTOLOAD has replaced module_autoload_iwlwifi, please replace it! Addresses bug: [YOCTO #6460] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-fri2/recipes-kernel/linux')
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend2
-rw-r--r--meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend3
2 files changed, 2 insertions, 3 deletions
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
index 557cba13..7aaf53af 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
@@ -12,4 +12,4 @@ KBRANCH_fri2-noemgd = "standard/preempt-rt/fri2"
12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64" 12SRCREV_machine_pn-linux-yocto-rt_fri2-noemgd ?= "b669af08737562ef86e7cba328966d05222d3e64"
13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX" 13#SRCREV_meta_pn-linux-yocto-rt_fri2-noemgd ?= "XXX"
14 14
15module_autoload_iwlwifi = "iwlwifi" 15KERNEL_MODULE_AUTOLOAD += "iwlwifi"
diff --git a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 36907a51..14bb81a0 100644
--- a/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-fri2/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -18,5 +18,4 @@ LINUX_VERSION_fri2-noemgd = "3.10.38"
18SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473" 18SRCREV_meta_fri2-noemgd = "e1f26aeccfd43bc3d7e95873ceda469b631b8473"
19SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388" 19SRCREV_machine_fri2-noemgd = "02f7e63e56c061617957388c23bd5cf9b05c5388"
20 20
21module_autoload_iwlwifi = "iwlwifi" 21KERNEL_MODULE_AUTOLOAD += "iwlwifi"
22