summaryrefslogtreecommitdiffstats
path: root/meta-fishriver
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-05-18 09:19:31 -0700
committerDarren Hart <dvhart@linux.intel.com>2012-05-23 11:22:03 -0700
commita62c485edffed30ea95658760948fd50925adfb0 (patch)
tree6421f4982bd1557a73aaec1a189587ec1a2918c3 /meta-fishriver
parentcb711ad2d9606ab8b5679d3a96dcb16c07cb258b (diff)
downloadmeta-intel-a62c485edffed30ea95658760948fd50925adfb0.tar.gz
linux-yocto_3.0: Update KMACHINE and KBRANCH to play nice with new kerntools
The 3.0 based boards are lazy compared to our new modern ones. Without this patch, the linux-yocto-3.0 kernel do_patch() task would fail with: /srv/home/pokybuild/yocto-autobuilder/yocto-slave/cedartrail/build/build/tmp/sysroots/x86_64-linux/usr/bin/updateme: line 434: yocto/standard/cedartrail-standard.scc: No such file or directory Setting the KBRANCH explicitly avoids this issue. This brings the following recipes inline with the fri2 and sys940x BSPs. Fix proposed by Bruce Ashfield. Testing: Built linux-yocto_3.0 for all machines involved, including the nopvr, noemgd variants. All built linux-yocto_3.0 successfully. Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Tom Zanussi <tom.zanussi@intel.com> CC: Bruce Ashfield <bruce.ashfield@windriver.com> CC: Kishore Bodke <kishore.k.bodke@intel.com>
Diffstat (limited to 'meta-fishriver')
-rw-r--r--meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend
index 4d34c2ae..6ac6ef59 100644
--- a/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend
+++ b/meta-fishriver/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -1,7 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3COMPATIBLE_MACHINE_fishriver = "fishriver" 3COMPATIBLE_MACHINE_fishriver = "fishriver"
4KMACHINE_fishriver = "yocto/standard/fishriver" 4KMACHINE_fishriver = "fishriver"
5KBRANCH_fishriver = "yocto/standard/fishriver"
5KERNEL_FEATURES_append_fishriver += " cfg/smp.scc" 6KERNEL_FEATURES_append_fishriver += " cfg/smp.scc"
6 7
7SRCREV_machine_pn-linux-yocto_fishriver ?= "c139592c96722727a9f074515a4061c3820da1a6" 8SRCREV_machine_pn-linux-yocto_fishriver ?= "c139592c96722727a9f074515a4061c3820da1a6"