summaryrefslogtreecommitdiffstats
path: root/meta-emenlow
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-01-24 13:28:33 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-01-27 16:56:14 -0800
commit72b0d50869775e572c4167fd18810895f199a2c8 (patch)
treecfd57073da1d0baa466c69f58087ebe854e9f467 /meta-emenlow
parent8bde0fa9b53b6d974b9c46cd937e0dadf3e3b260 (diff)
downloadmeta-intel-72b0d50869775e572c4167fd18810895f199a2c8.tar.gz
emenlow: Set PACKAGE_ARCH to MACHINE_ARCH explicitly
The new intel-common.inc sets the default of the PACKAGE_ARCH for the linux-yocto kernel recipes to DEFAULTTUNE_kernel. Revert the existing recipes to MACHINE_ARCH until they can be removed in favor of a more unified mechanism. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-emenlow')
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend3
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend1
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend1
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend3
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend3
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend3
6 files changed, 14 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
index e540b2fc..419e501a 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
4PACKAGE_ARCH_emenlow-noemgd = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_emenlow = "emenlow" 6COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 7KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 8KBRANCH_emenlow = "standard/emenlow"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
index 15fc8473..3bc4684c 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -1,4 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
2COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
3KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
4 5
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
index 15fc8473..3bc4684c 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-rt_3.8.bbappend
@@ -1,4 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
2COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
3KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
4 5
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
index 802e4465..2381d95b 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
4PACKAGE_ARCH_emenlow-noemgd = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_emenlow = "emenlow" 6COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 7KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 8KBRANCH_emenlow = "standard/emenlow"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 34bdc7d8..b4971569 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
4PACKAGE_ARCH_emenlow-noemgd = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_emenlow = "emenlow" 6COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 7KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 8KBRANCH_emenlow = "standard/emenlow"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 14a2bb08..b4a8c004 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_emenlow = "${MACHINE_ARCH}"
4PACKAGE_ARCH_emenlow-noemgd = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_emenlow = "emenlow" 6COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 7KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 8KBRANCH_emenlow = "standard/emenlow"