summaryrefslogtreecommitdiffstats
path: root/meta-emenlow
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-07-16 17:19:22 (GMT)
committerTom Zanussi <tom.zanussi@intel.com>2013-07-19 18:41:30 (GMT)
commit119eb42cd5705cf7ec920d1180c5dde94d293e9e (patch)
treeb2d38db007fbe021a47500948951960989704113 /meta-emenlow
parent63beadd34de47265058095860237cc20cbc4b411 (diff)
downloadmeta-intel-119eb42cd5705cf7ec920d1180c5dde94d293e9e.tar.gz
emenlow: update to use emgd 1.18 user recipe
Updating the bsp to use version 1.18 of emgd userland recipe. Update EMGD version in the README. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow')
-rw-r--r--meta-emenlow/README8
-rw-r--r--meta-emenlow/conf/machine/emenlow.conf2
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-emenlow/README b/meta-emenlow/README
index 9aca0f3..3049fe5 100644
--- a/meta-emenlow/README
+++ b/meta-emenlow/README
@@ -85,7 +85,7 @@ common metadata shared between BSPs) e.g.:
85The meta-emenlow layer contains support for two different machine 85The meta-emenlow layer contains support for two different machine
86configurations. These configurations are identical except for the fact 86configurations. These configurations are identical except for the fact
87that the one prefixed with 'emenlow' makes use of the 87that the one prefixed with 'emenlow' makes use of the
88Intel-proprietary EMGD 1.16 graphics driver, while the one prefixed 88Intel-proprietary EMGD 1.18 graphics driver, while the one prefixed
89with 'emenlow-noemgd' does not. The 'emenlow-noemgd' machine 89with 'emenlow-noemgd' does not. The 'emenlow-noemgd' machine
90configuration instead uses the open source 'gma500' kernel DRM driver 90configuration instead uses the open source 'gma500' kernel DRM driver
91along with the 'modesetting' X driver. 91along with the 'modesetting' X driver.
@@ -97,10 +97,10 @@ following to the local.conf file:
97 97
98The 'emenlow' machine includes the emgd-driver-bin package, which has 98The 'emenlow' machine includes the emgd-driver-bin package, which has
99a proprietary license that must be whitelisted by adding the string 99a proprietary license that must be whitelisted by adding the string
100"license_emgd-driver-bin_1.16" to the LICENSE_FLAGS_WHITELIST variable 100"license_emgd-driver-bin_1.18" to the LICENSE_FLAGS_WHITELIST variable
101in your local.conf. For example: 101in your local.conf. For example:
102 102
103 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16" 103 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin"
104 104
105If you want to enable the layer that does not support EMGD graphics 105If you want to enable the layer that does not support EMGD graphics
106add the following to the local.conf file: 106add the following to the local.conf file:
@@ -122,7 +122,7 @@ added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
122 122
123For example: 123For example:
124 124
125 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin_1.16 commercial" 125 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin commercial"
126 126
127The reason this is needed is to prevent the image from including 127The reason this is needed is to prevent the image from including
128anything that might violate the license terms of the packages used to 128anything that might violate the license terms of the packages used to
diff --git a/meta-emenlow/conf/machine/emenlow.conf b/meta-emenlow/conf/machine/emenlow.conf
index 8dfb433..f1b3620 100644
--- a/meta-emenlow/conf/machine/emenlow.conf
+++ b/meta-emenlow/conf/machine/emenlow.conf
@@ -27,7 +27,7 @@ PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
27PREFERRED_VERSION_mesa ?= "9.1.3" 27PREFERRED_VERSION_mesa ?= "9.1.3"
28PREFERRED_VERSION_xf86-input-synaptics ?= "1.6.3" 28PREFERRED_VERSION_xf86-input-synaptics ?= "1.6.3"
29PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0" 29PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
30PREFERRED_VERSION_emgd-driver-bin ?= "1.16" 30PREFERRED_VERSION_emgd-driver-bin ?= "1.18"
31PREFERRED_VERSION_libva ?= "1.0.16" 31PREFERRED_VERSION_libva ?= "1.0.16"
32 32
33APPEND += "video=vesafb vga=0x318 vmalloc=256MB" 33APPEND += "video=vesafb vga=0x318 vmalloc=256MB"