summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-kernel
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-07-26 18:30:51 -0700
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-07-29 13:41:21 -0500
commit84fdca145a19d4715e2d743dd7b45c20e8ed9691 (patch)
treec3c195c0b4a764f2fbc70cb24528786b72b06be9 /meta-emenlow/recipes-kernel
parent75ac6a2a98fe76653dfb55da5c5afd592ec18acb (diff)
downloadmeta-intel-84fdca145a19d4715e2d743dd7b45c20e8ed9691.tar.gz
emenlow: correct the KERNEL_FEATURE variable name
The var KERNEL_FEATURES_sugarbay_append overrides the previous value defined in the oecore layer, and the var KERNEL_FEATURES_append_sugarbay preserves the old value and extends it. This change avoids unintentional disabling of some KERNEL_FEATURES such as netfilter. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'meta-emenlow/recipes-kernel')
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend4
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend4
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend4
3 files changed, 6 insertions, 6 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
index 54c4abd2..00ab0fd7 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -3,12 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb" 6KERNEL_FEATURES_append_emenlow = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd" 8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow" 9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow" 10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600" 11KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma600"
12 12
13SRCREV_machine_emenlow = "60536206ad300ccf5b2be2c2d449f4ab27170238" 13SRCREV_machine_emenlow = "60536206ad300ccf5b2be2c2d449f4ab27170238"
14SRCREV_meta_emenlow = "fe20c99783387dab779472ff50a88666da1c6391" 14SRCREV_meta_emenlow = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 0b55e493..34bdc7d8 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -3,12 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb" 6KERNEL_FEATURES_append_emenlow = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd" 8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow" 9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow" 10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600" 11KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma600"
12 12
13SRCREV_machine_pn-linux-yocto_emenlow ?= "0a1e7660733615106a2430e38bf6b835a8e5507d" 13SRCREV_machine_pn-linux-yocto_emenlow ?= "0a1e7660733615106a2430e38bf6b835a8e5507d"
14SRCREV_meta_pn-linux-yocto_emenlow ?= "9473a39c59bf9c07a316486d272652bacb9ad3ac" 14SRCREV_meta_pn-linux-yocto_emenlow ?= "9473a39c59bf9c07a316486d272652bacb9ad3ac"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
index fb8d9567..394ed6e4 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -3,12 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3COMPATIBLE_MACHINE_emenlow = "emenlow" 3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow" 5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.18 cfg/vesafb" 6KERNEL_FEATURES_append_emenlow = " features/drm-emgd/drm-emgd-1.18 cfg/vesafb"
7 7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd" 8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow" 9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow" 10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600" 11KERNEL_FEATURES_append_emenlow-noemgd = " features/drm-gma500/drm-gma600"
12 12
13LINUX_VERSION = "3.8.13" 13LINUX_VERSION = "3.8.13"
14 14