summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-kernel
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-02-04 10:39:06 -0600
committerTom Zanussi <tom.zanussi@linux.intel.com>2013-02-04 10:39:06 -0600
commit575f93dd4ba1fb9aca8a58dc66e9066eca0a3925 (patch)
tree7f6bbda197c7c01a1e87d9ee7e5a0616128ed399 /meta-emenlow/recipes-kernel
parent706a62e662dde79bc4e7ec0f81b76890e49f4beb (diff)
downloadmeta-intel-575f93dd4ba1fb9aca8a58dc66e9066eca0a3925.tar.gz
meta-intel: remove kernel AUTOREVs
Using AUTOREV turns out to cause problems with unreproducible autobuilder builds and unwanted network access. This patch removes kernel AUTOREVs and locks down SRCREVs and LINUX_VERSIONs. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Diffstat (limited to 'meta-emenlow/recipes-kernel')
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.2.bbappend6
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend12
2 files changed, 11 insertions, 7 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.2.bbappend
index 9752706a..24d8ec76 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.2.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -4,5 +4,7 @@ COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow" 4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/default/emenlow" 5KBRANCH_emenlow = "standard/default/emenlow"
6 6
7SRCREV_machine_pn-linux-yocto_emenlow ?= "${AUTOREV}" 7SRCREV_machine_pn-linux-yocto_emenlow ?= "a0dbaa15a7b42122449c4069a55b6bc60b579ee7"
8SRCREV_meta_pn-linux-yocto_emenlow ?= "${AUTOREV}" 8SRCREV_meta_pn-linux-yocto_emenlow ?= "e7f2fdc48f8808887175f0328274a2668084738c"
9
10LINUX_VERSION = "3.2.32"
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 3eff5dd8..4a46c594 100644
--- a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -10,11 +10,13 @@ KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow" 10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600" 11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600"
12 12
13SRCREV_machine_pn-linux-yocto_emenlow ?= "${AUTOREV}" 13SRCREV_machine_pn-linux-yocto_emenlow ?= "38909cd5415a3a6c237ab2e880c57e853b3b472f"
14SRCREV_meta_pn-linux-yocto_emenlow ?= "${AUTOREV}" 14SRCREV_meta_pn-linux-yocto_emenlow ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0"
15SRCREV_emgd_pn-linux-yocto_emenlow ?= "${AUTOREV}" 15SRCREV_emgd_pn-linux-yocto_emenlow ?= "08f65e2611877f7339a0626ab1c7255a35787adb"
16 16
17SRCREV_machine_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}" 17SRCREV_machine_pn-linux-yocto_emenlow-noemgd ?= "38909cd5415a3a6c237ab2e880c57e853b3b472f"
18SRCREV_meta_pn-linux-yocto_emenlow-noemgd ?= "${AUTOREV}" 18SRCREV_meta_pn-linux-yocto_emenlow-noemgd ?= "f697e099bc76d5df3a307a5bc0cc25021dd6dfe0"
19 19
20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd" 20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"
21
22LINUX_VERSION = "3.4.28"