summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-kernel
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-04 11:39:25 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-03-06 15:34:25 -0600
commit5024cb9c7c67dad48eb303029666300ff1bc543e (patch)
treed7c1ac852989e8cfba24efb7996cc75fc846ff1d /meta-emenlow/recipes-kernel
parentf36ee29ff19ffd84b151a1504e03ae84bcccb91c (diff)
downloadmeta-intel-5024cb9c7c67dad48eb303029666300ff1bc543e.tar.gz
emenlow: linux-yocto_3.8 recipe extension
Provide the emenlow BSP specific extension for the linux-yocto_3.8 recipe from the oecore layer. This configures the right git branches of the kernel repository for the emenlow BSP. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-kernel')
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 00000000..c272d27f
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_emenlow = "emenlow"
4KMACHINE_emenlow = "emenlow"
5KBRANCH_emenlow = "standard/emenlow"
6KERNEL_FEATURES_emenlow_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7
8COMPATIBLE_MACHINE_emenlow-noemgd = "emenlow-noemgd"
9KMACHINE_emenlow-noemgd = "emenlow"
10KBRANCH_emenlow-noemgd = "standard/emenlow"
11KERNEL_FEATURES_emenlow-noemgd_append = " features/drm-gma500/drm-gma600"
12
13SRCREV_meta_emenlow = "c2ed0f16fdec628242a682897d5d86df4547cf24"
14SRCREV_machine_emenlow = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
15SRCREV_emgd_emenlow = "caea08c988e0f41103bbe18eafca20348f95da02"
16
17SRCREV_meta_emenlow-noemgd = "c2ed0f16fdec628242a682897d5d86df4547cf24"
18SRCREV_machine_emenlow-noemgd = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
19
20SRC_URI_emenlow = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"