diff options
author | Darren Hart <dvhart@linux.intel.com> | 2011-05-25 12:01:11 -0700 |
---|---|---|
committer | Darren Hart <dvhart@linux.intel.com> | 2011-05-27 09:47:56 -0700 |
commit | e94dba8309874a82a570db60223d18b2c723c3a5 (patch) | |
tree | 8e353e8ca7aee25c2bdb10b63d1fcb0f6842787a /meta-emenlow/recipes-kernel | |
parent | b0f4192e67e3140e41870b967977a2440a415c93 (diff) | |
download | meta-intel-e94dba8309874a82a570db60223d18b2c723c3a5.tar.gz |
linux-yocto*: correct FILESEXTRAPATHS assignment in all layers
My previous commit used a self referencing immediate expansion assignment using.
This causes a circular reference and build failure, particularly when more than
one layer is configured in.
Use the _prepend mechanism in conjunction with the immediate expansion
assignment operator to accomplish a similar thing without the self referencing.
Note: This patch is dependent on changes to oe-core, specifically:
http://lists.linuxtogo.org/pipermail/openembedded-core/2011-May/003145.html
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Cc: Tom Zanussi <tom.zanussi@intel.com>
Cc: Phill Blundell <pb@pbcl.net>
Cc: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-emenlow/recipes-kernel')
-rw-r--r-- | meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend | 2 | ||||
-rw-r--r-- | meta-emenlow/recipes-kernel/linux/linux-yocto_git.bbappend | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend index 09234dcd..77a665d0 100644 --- a/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend +++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | COMPATIBLE_MACHINE_emenlow = "emenlow" | 2 | COMPATIBLE_MACHINE_emenlow = "emenlow" |
3 | KMACHINE_emenlow = "emenlow" | 3 | KMACHINE_emenlow = "emenlow" |
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto_git.bbappend index 3d7e021d..05307b74 100644 --- a/meta-emenlow/recipes-kernel/linux/linux-yocto_git.bbappend +++ b/meta-emenlow/recipes-kernel/linux/linux-yocto_git.bbappend | |||
@@ -1,3 +1,3 @@ | |||
1 | FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | COMPATIBLE_MACHINE_emenlow = "emenlow" | 2 | COMPATIBLE_MACHINE_emenlow = "emenlow" |
3 | KMACHINE_emenlow = "yocto/standard/emenlow" | 3 | KMACHINE_emenlow = "yocto/standard/emenlow" |