summaryrefslogtreecommitdiffstats
path: root/meta-crystalforest
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2014-01-24 13:28:33 -0800
committerDarren Hart <dvhart@linux.intel.com>2014-01-27 16:56:14 -0800
commit8bde0fa9b53b6d974b9c46cd937e0dadf3e3b260 (patch)
tree330f8effea31c94b547286c2c4cb810f7ad97f05 /meta-crystalforest
parent587ac72206cadf36594a911a71251089901a3f0d (diff)
downloadmeta-intel-8bde0fa9b53b6d974b9c46cd937e0dadf3e3b260.tar.gz
crystalforest: Set PACKAGE_ARCH to MACHINE_ARCH explicitly
The new intel-common.inc sets the default of the PACKAGE_ARCH for the linux-yocto kernel recipes to DEFAULTTUNE_kernel. Revert the existing recipes to MACHINE_ARCH until they can be removed in favor of a more unified mechanism. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-crystalforest')
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend3
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend3
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend3
-rw-r--r--meta-crystalforest/recipes-kernel/linux/linux-yocto_3.8.bbappend3
4 files changed, 12 insertions, 0 deletions
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
index e98d03f6..37474e30 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto-rt_3.4.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_crystalforest-gladden = "${MACHINE_ARCH}"
4PACKAGE_ARCH_crystalforest-server = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladen" 6COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladen"
4KMACHINE_crystalforest-gladden = "crystalforest" 7KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-gladden = "standard/preempt-rt/base" 8KBRANCH_crystalforest-gladden = "standard/preempt-rt/base"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
index f3f036e9..f93bb711 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_crystalforest-gladden = "${MACHINE_ARCH}"
4PACKAGE_ARCH_crystalforest-server = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden" 6COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
4KMACHINE_crystalforest-gladden = "crystalforest" 7KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest" 8KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
index e7cf16d1..ed9ee3c8 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_crystalforest-gladden = "${MACHINE_ARCH}"
4PACKAGE_ARCH_crystalforest-server = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden" 6COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
4KMACHINE_crystalforest-gladden = "crystalforest" 7KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest" 8KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"
diff --git a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
index 47a24372..31125178 100644
--- a/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
+++ b/meta-crystalforest/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -1,5 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PACKAGE_ARCH_crystalforest = "${MACHINE_ARCH}"
4PACKAGE_ARCH_crystalforest-server = "${MACHINE_ARCH}"
5
3COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden" 6COMPATIBLE_MACHINE_crystalforest-gladden = "crystalforest-gladden"
4KMACHINE_crystalforest-gladden = "crystalforest" 7KMACHINE_crystalforest-gladden = "crystalforest"
5KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest" 8KBRANCH_crystalforest-gladden = "standard/common-pc-64/crystalforest"