summaryrefslogtreecommitdiffstats
path: root/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb
diff options
context:
space:
mode:
authorvenkatasubramanian pattu <venkatasubramanianx.pattu@intel.com>2015-07-10 18:57:41 +0800
committerSaul Wold <sgw@linux.intel.com>2015-07-10 08:14:53 -0700
commit9511d5564160384b4e9f8a88f59d6f90f6ca0e0e (patch)
tree65f6f6ff389dbfac686d57187ada8e4367e85ee7 /meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb
parent33d6adf928441406e348ceb008d8ebaa98a0da10 (diff)
downloadmeta-intel-9511d5564160384b4e9f8a88f59d6f90f6ca0e0e.tar.gz
meta-crystalforest: Zlib QAT_MEM MM Module
The zlib software library and the Intel QuickAssist Technology both implement the deflate algorithm as described in RFC 1951. This software accelerates the data compression algorithm in the zlib software library via the Intel QuickAssist Technology implemented on Intel Communications Chipsets. Signed-off-by: venkatasubramanian pattu <venkatasubramanianx.pattu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> (Imported from meta-intel commit 3ee02a36e0d1126fda0c6ea6a1bef4db08b8be7a) Changed the kernel module build patch to align with fido to make sure that the kernel module compiles. Added KERNEL_BUILDDIR to point to kernel build. Signed-off-by: Anuj Mittal <anujx.mittal@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb')
-rw-r--r--meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb111
1 files changed, 111 insertions, 0 deletions
diff --git a/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb
new file mode 100644
index 00000000..514a15dc
--- /dev/null
+++ b/meta-crystalforest/recipes-extended/zlib-qat/zlib-qat.bb
@@ -0,0 +1,111 @@
1SUMMARY = "Zlib QAT_MEM Memory Management Module for Intel Quick Assist \
2Technology"
3
4DESCRIPTION = "This software acelerates the data compression algorithm \
5in the zlib software library via the Intel QuickAssist Technology \
6implemented on Intel Communications Chipset 89xx and 895x Series based platforms."
7
8HOMEPAGE = "http://zlib.net/"
9SECTION = "libs"
10LICENSE = "Zlib & GPLv2 & BSD"
11LIC_FILES_CHKSUM = "file://${WORKDIR}/zlib-${ZLIB_VERSION}/zlib.h;beginline=4;endline=23;md5=fde612df1e5933c428b73844a0c494fd \
12 file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
13 file://${COMMON_LICENSE_DIR}/BSD;md5=3775480a712fc46a69647678acb234cb"
14
15# For target side versions of openssl enable support for OCF Linux driver
16# if they are available.
17DEPENDS += "cryptodev-linux pkgconfig qat16"
18
19SRC_URI = "http://www.zlib.net/zlib-${ZLIB_VERSION}.tar.gz;name=zlib \
20 https://01.org/sites/default/files/page/zlib_shim_0.4.7-002_withdocumentation.zip;name=zlibqat \
21 file://zlib-qat-0.4.7-002-qat_mem-build-qat_mem-ko-against-yocto-kernel-src.patch \
22 "
23
24SRC_URI[zlib.md5sum] = "44d667c142d7cda120332623eab69f40"
25SRC_URI[zlib.sha256sum] = "36658cb768a54c1d4dec43c3116c27ed893e88b02ecfcb44f2166f9c0b7f2a0d"
26
27SRC_URI[zlibqat.md5sum] = "dfde8618198aa8d35ecc00d10dcc7000"
28SRC_URI[zlibqat.sha256sum] = "8e5786400bbc2a879ae705c864ec63b53ae019b4f2d1c94524a97223847b6e46"
29
30ZLIB_VERSION = "1.2.8"
31ZLIB_QAT_VERSION = "0.4.7-002"
32
33S = "${WORKDIR}/zlib-${ZLIB_VERSION}"
34
35export ICP_ROOT = "${PKG_CONFIG_SYSROOT_DIR}"
36export ZLIB_ROOT = "${S}"
37export ICP_ZLIBQAT = "${S}"
38export ICP_BUILD_OUTPUT = "${ICP_ROOT}/lib"
39export KERNEL_SOURCE_ROOT = "${STAGING_KERNEL_DIR}"
40export KERNEL_BUILDDIR = "${STAGING_KERNEL_BUILDDIR}"
41
42CFLAGS += "\
43 -I${ICP_ROOT}/usr/include \
44 -I${ICP_ROOT}/usr/include/dc \
45 -I${ZLIB_ROOT}/ \
46 -D_LARGEFILE64_SOURCE=1 -DHAVE_HIDDEN -DUSE_QAT_MEM -I${ZLIB_ROOT}/contrib/qat/qat_mem -D_GNU_SOURCE \
47 -L${ZLIB_ROOT} -lz \
48 -L${ICP_ROOT}/usr/lib/ -lpthread -lcrypto -ldl -lrt \
49 -L${ICP_ROOT}/usr/lib/ -licp_qa_al -losal -ladf_proxy"
50
51inherit module
52MODULE_DIR = "${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers"
53MEM_PATH = "${S}/contrib/qat"
54
55do_unpack2(){
56 cd ${WORKDIR}/
57 unzip zlib_quickassist_patch_l.0.4.7_002_stable.zip
58 cd zlib_quickassist_patch_l.0.4.7_002_devbranch
59 tar -xvzf zlib-1.2.8-qat.L.0.4.7-002.tar.gz
60 cp zlib-1.2.8-qat.patch ${WORKDIR}
61}
62
63addtask unpack2 after do_unpack before do_patch
64
65do_patch() {
66 cd ${S}
67 patch -p1 < ${WORKDIR}/zlib-1.2.8-qat.patch
68 patch -p1 < ${WORKDIR}/zlib-qat-0.4.7-002-qat_mem-build-qat_mem-ko-against-yocto-kernel-src.patch
69}
70
71do_configure() {
72 cd ${S}
73 ./configure
74}
75
76do_compile() {
77 EXTRA_OEMAKE="'CFLAGS=${CFLAGS} -fPIC'"
78 cd ${MEM_PATH}/qat_mem/
79 oe_runmake
80 cd ${S}/
81 oe_runmake
82 cd ${MEM_PATH}/qat_zlib_test/
83 oe_runmake
84}
85
86do_install() {
87 chrpath -d ${MEM_PATH}/qat_zlib_test/comptestapp
88 install -m 0755 -d ${MODULE_DIR}/
89 install -m 0755 -d ${D}${bindir}/
90 install -m 0755 -d ${D}${sysconfdir}/zlib_conf/
91 install -m 640 ${MEM_PATH}/qat_mem/qat_mem.ko ${MODULE_DIR}/
92 install -m 0755 ${WORKDIR}/zlib-${ZLIB_VERSION}/zpipe ${D}${bindir}/
93 install -m 0755 ${WORKDIR}/zlib-${ZLIB_VERSION}/minigzip ${D}${bindir}/
94 install -m 0755 ${MEM_PATH}/qat_zlib_test/comptestapp ${D}${bindir}/
95 install -m 660 ${MEM_PATH}/config/dh895xcc/multi_thread_optimized/* ${D}${sysconfdir}/zlib_conf/
96 install -m 660 ${MEM_PATH}/config/dh89xxcc/multi_thread_optimized/* ${D}${sysconfdir}/zlib_conf/
97}
98
99PACKAGES += "${PN}-app"
100
101FILES_${PN} += " \
102 ${sysconfdir}/zlib_conf/ \
103 "
104
105FILES_${PN}-app += " \
106 ${bindir}/* \
107 "
108
109FILES_${PN}-dbg += " \
110 ${bindir}/.debug \
111 "