summaryrefslogtreecommitdiffstats
path: root/meta-crownbay
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-17 13:05:46 -0600
committerSaul Wold <sgw@linux.intel.com>2011-01-03 16:46:31 -0800
commitbe72384306c4dcc88b4866db743e7e501c6fa830 (patch)
tree0a54a82918fb68703b14036e0365b2e5c3178431 /meta-crownbay
parent158f88d76685da4e71a21f3788d519dd4b2bb912 (diff)
downloadmeta-intel-be72384306c4dcc88b4866db743e7e501c6fa830.tar.gz
meta-crownbay: add a machine configuration that doesn't use EMGD graphics
This adds a second machine to the meta-crownbay BSP that uses generic vesa graphics instead of the Intel-proprietary straight 'crownbay' version that does. The name of the new machine is 'crownbay-noemgd'. Though the graphics quality isn't as nice, the binaries for this version can be distributed without any need for license click-throughs or the manual step currently required for the EMGD version. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay')
-rw-r--r--meta-crownbay/conf/layer.conf6
-rw-r--r--meta-crownbay/conf/machine/crownbay-noemgd.conf45
-rw-r--r--meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig3
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf26
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend4
5 files changed, 83 insertions, 1 deletions
diff --git a/meta-crownbay/conf/layer.conf b/meta-crownbay/conf/layer.conf
index 52581e1c..cee4ba24 100644
--- a/meta-crownbay/conf/layer.conf
+++ b/meta-crownbay/conf/layer.conf
@@ -5,6 +5,10 @@ BBPATH := "${BBPATH}:${LAYERDIR}"
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ 5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend" 6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7 7
8BBFILE_COLLECTIONS += "crownbay" 8BBFILE_COLLECTIONS_crownbay += "crownbay"
9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/" 9BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
10BBFILE_PRIORITY_crownbay = "6" 10BBFILE_PRIORITY_crownbay = "6"
11
12BBFILE_COLLECTIONS_crownbay-noemgd += "crownbay-noemgd"
13BBFILE_PATTERN_crownbay-noemgd := "^${LAYERDIR}/"
14BBFILE_PRIORITY_crownbay-noemgd = "6"
diff --git a/meta-crownbay/conf/machine/crownbay-noemgd.conf b/meta-crownbay/conf/machine/crownbay-noemgd.conf
new file mode 100644
index 00000000..535cf55e
--- /dev/null
+++ b/meta-crownbay/conf/machine/crownbay-noemgd.conf
@@ -0,0 +1,45 @@
1#@TYPE: Machine
2#@NAME: crownbay-noemgd
3
4#@DESCRIPTION: Machine configuration for Crown Bay systems, without Intel-proprietary graphics bits
5# i.e. E660 + EG20T
6
7TARGET_ARCH = "i586"
8PACKAGE_EXTRA_ARCHS = "x86 atom"
9
10include conf/machine/include/tune-atom.inc
11
12BASE_PACKAGE_ARCH="atom"
13
14MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
15 acpi serial usbgadget"
16
17KERNEL_IMAGETYPE = "bzImage"
18
19PREFERRED_PROVIDER_virtual/kernel ?= "linux-wrs"
20PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
21PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
22PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
23PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
24XSERVER ?= "xserver-xf86-dri-lite \
25 xf86-input-mouse \
26 xf86-input-keyboard \
27 xf86-input-evdev \
28 xf86-input-synaptics \
29 xf86-video-vesa"
30
31SERIAL_CONSOLE = "115200 ttyS0"
32
33MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
34
35GUI_MACHINE_CLASS = "bigscreen"
36
37IMAGE_ROOTFS_SIZE_ext3 = "2000000"
38
39IMAGE_FSTYPES ?= "ext3 cpio.gz"
40
41GLIBC_ADDONS = "nptl"
42GLIBC_EXTRA_OECONF = "--with-tls"
43
44SRCREV_machine_pn-linux-wrs_crownbay-noemgd = "f0afe10edaed24575eb115ad69c366fc24ea9380"
45SRCREV_meta_pn-linux-wrs = "2f315f96f26a93d22fe0fc524de629e7c46b8469"
diff --git a/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf
new file mode 100644
index 00000000..da4fc3c6
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay-noemgd/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Generic VESA"
3 Driver "vesa"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Generic VESA"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
index 9709c365..aebe789a 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-wrs_git.bbappend
@@ -1,3 +1,7 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}" 1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2
2COMPATIBLE_MACHINE_crownbay = "crownbay" 3COMPATIBLE_MACHINE_crownbay = "crownbay"
3WRMACHINE_crownbay = "crownbay" 4WRMACHINE_crownbay = "crownbay"
5
6COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
7WRMACHINE_crownbay-noemgd = "crownbay"