summaryrefslogtreecommitdiffstats
path: root/meta-crownbay
diff options
context:
space:
mode:
authorMarc Ferland <marc.ferland@gmail.com>2011-05-19 11:00:31 -0700
committerTom Zanussi <tom.zanussi@intel.com>2011-05-19 20:17:22 -0500
commit54a572b1d4d4bfd018fc969cc2a4e1c3ba66bb39 (patch)
tree22d83ff8febd6c6ec2aeec0b382de571f1efb86e /meta-crownbay
parent6e35713d9f7dbbc2682811234c804a5b129d04e2 (diff)
downloadmeta-intel-54a572b1d4d4bfd018fc969cc2a4e1c3ba66bb39.tar.gz
Add SMP support to crownbay.
This patch fixes Yocto BUG #1015. It adds support for SMP on the crownbay architecture from the meta-intel branch. Signed-off-by: Marc Ferland <ferlandm@sonatest.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay')
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto-stable_git.bbappend2
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto_git.bbappend2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto-stable_git.bbappend
index 83094789..44f892fd 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-yocto-stable_git.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto-stable_git.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}"
2 2
3COMPATIBLE_MACHINE_crownbay = "crownbay" 3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "crownbay" 4KMACHINE_crownbay = "crownbay"
5KERNEL_FEATURES_append_crownbay += " cfg/smp.scc"
5 6
6COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd" 7COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
7KMACHINE_crownbay-noemgd = "crownbay" 8KMACHINE_crownbay-noemgd = "crownbay"
9KERNEL_FEATURES_append_crownbay-noemgd += " cfg/smp.scc"
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto_git.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto_git.bbappend
index 176acd3f..387c2079 100644
--- a/meta-crownbay/recipes-kernel/linux/linux-yocto_git.bbappend
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto_git.bbappend
@@ -2,6 +2,8 @@ FILESEXTRAPATHS := "${FILESEXTRAPATHS}:${THISDIR}/${PN}"
2 2
3COMPATIBLE_MACHINE_crownbay = "crownbay" 3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "yocto/standard/crownbay" 4KMACHINE_crownbay = "yocto/standard/crownbay"
5KERNEL_FEATURES_append_crownbay += " cfg/smp.scc"
5 6
6COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd" 7COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
7KMACHINE_crownbay-noemgd = "yocto/standard/crownbay" 8KMACHINE_crownbay-noemgd = "yocto/standard/crownbay"
9KERNEL_FEATURES_append_crownbay-noemgd += " cfg/smp.scc"