summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/recipes-kernel
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-02-25 11:11:42 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-03-04 16:55:21 -0600
commit6a0fb2873bac9bad66758632952168e66d59e95e (patch)
tree9a37cd1f9102886727b154b510eb78ffa412d3fd /meta-crownbay/recipes-kernel
parentc909152f7e6eb2119a775dc23d1d4924effe4686 (diff)
downloadmeta-intel-6a0fb2873bac9bad66758632952168e66d59e95e.tar.gz
crownbay: linux-yocto-dev recipe extension
Provide the crownbay BSP specific extension for the linux-yocto-dev recipe from the oecore layer. This configures the right git branches of the kernel repository for the crownbay BSP. This commit is addressing this bug: [YOCTO #3931] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay/recipes-kernel')
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..10bced84
--- /dev/null
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "crownbay"
5KBRANCH_crownbay = "standard/crownbay"
6KERNEL_FEATURES_crownbay_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7
8COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
9KMACHINE_crownbay-noemgd = "crownbay"
10KBRANCH_crownbay-noemgd = "standard/crownbay"
11KERNEL_FEATURES_crownbay-noemgd_append = " cfg/vesafb"
12
13SRCREV_meta_crownbay = "fe20c99783387dab779472ff50a88666da1c6391"
14SRCREV_machine_crownbay = "60536206ad300ccf5b2be2c2d449f4ab27170238"
15SRCREV_emgd_crownbay = "17aacd908ed6035213a6d206cfdb2c0c9fa9e0c1"
16
17SRCREV_machine_crownbay-noemgd = "60536206ad300ccf5b2be2c2d449f4ab27170238"
18SRCREV_meta_crownbay-noemgd = "fe20c99783387dab779472ff50a88666da1c6391"
19
20SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-dev.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"