summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-04 11:37:54 -0800
committerTom Zanussi <tom.zanussi@intel.com>2013-03-06 15:34:12 -0600
commitf36ee29ff19ffd84b151a1504e03ae84bcccb91c (patch)
tree782d3e6c74ca05a405b2a9b3c0223ddb4425e0d0 /meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend
parentb77b3504de890b90f0e9ad4547fd254550f2daa7 (diff)
downloadmeta-intel-f36ee29ff19ffd84b151a1504e03ae84bcccb91c.tar.gz
crownbay: linux-yocto_3.8 recipe extension
Provide the crownbay BSP specific extension for the linux-yocto_3.8 recipe from the oecore layer. This configures the right git branches of the kernel repository for the crownbay BSP. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend')
-rw-r--r--meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 00000000..08f6125d
--- /dev/null
+++ b/meta-crownbay/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,20 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_crownbay = "crownbay"
4KMACHINE_crownbay = "crownbay"
5KBRANCH_crownbay = "standard/crownbay"
6KERNEL_FEATURES_crownbay_append = " features/drm-emgd/drm-emgd-1.16 cfg/vesafb"
7
8COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
9KMACHINE_crownbay-noemgd = "crownbay"
10KBRANCH_crownbay-noemgd = "standard/crownbay"
11KERNEL_FEATURES_crownbay-noemgd_append = " cfg/vesafb"
12
13SRCREV_meta_crownbay = "c2ed0f16fdec628242a682897d5d86df4547cf24"
14SRCREV_machine_crownbay = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
15SRCREV_emgd_crownbay = "caea08c988e0f41103bbe18eafca20348f95da02"
16
17SRCREV_meta_crownbay-noemgd = "c2ed0f16fdec628242a682897d5d86df4547cf24"
18SRCREV_machine_crownbay-noemgd = "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
19
20SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"