summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/recipes-graphics
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-13 22:40:15 -0600
committerSaul Wold <sgw@linux.intel.com>2011-01-03 16:45:27 -0800
commit7059fe6442b0cf480261fbcdea3e5ba404afef27 (patch)
tree229efc2453e72560d5d89551753d388f36fb2c61 /meta-crownbay/recipes-graphics
parentc14f24a2e9aebaaf2edb005f9480b395a8618acf (diff)
downloadmeta-intel-7059fe6442b0cf480261fbcdea3e5ba404afef27.tar.gz
meta-crownbay: new layer for E6xx/EG20T systems
This layer provides support for Tunnel Creek + Topcliff Intel systems to laverne (0.90). It supports the E6xx embedded on-chip graphics via the Intel Embedded Media and Graphics Driver (EMGD) 1.5 Gold Driver. The EMGD and EG20T PCH kernel drivers are of course GPL'ed and are submitted in a separate patchset for the 2.6.34 yocto kernel. The userspace X drivers and supporting libraries however are closed and need to be manually copied into the layer before building. The details on how to do this can be found in the README doc in meta-crownbay/. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay/recipes-graphics')
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf47
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore0
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb90
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch19
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch13
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch18
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch12
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb25
9 files changed, 227 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf
new file mode 100644
index 00000000..f78a538a
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf
@@ -0,0 +1,47 @@
1##
2## X Config options generated from CED
3## x11 conf skeleton
4## DriverVer=
5##
6
7Section "Screen"
8 Identifier "Screen0"
9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
13EndSection
14
15# Primary (First/only) display
16Section "Device"
17 Identifier "IntelEMGD-0"
18 Driver "emgd"
19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "40000"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/Port/4/General/name" "lvds"
30 Option "ALL/1/Port/4/General/EdidAvail" "3"
31 Option "ALL/1/Port/4/General/EdidNotAvail" "1"
32 Option "ALL/1/Port/4/General/Rotation" "0"
33 Option "ALL/1/Port/4/General/Edid" "1"
34EndSection
35
36Section "ServerLayout"
37 Identifier "Default Layout"
38 Screen 0 "Screen0" 0 0
39 # InputDevice "Mouse0" "CorePointer"
40 # InputDevice "Keyboard0" "CoreKeyboard"
41 # InputDevice "DevInputMice" "SendCoreEvents"
42EndSection
43
44Section "ServerFlags"
45 Option "DontZap" "0"
46 Option "AutoAddDevices" "False"
47EndSection
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin/.gitignore
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
new file mode 100644
index 00000000..95068722
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
@@ -0,0 +1,90 @@
1SUMMARY = "EMGD 1.5 xserver binaries"
2DESCRIPTION = "EMGD 1.5 includes some userspace binaries that use non-free licensing. Intel Open Source Technology Center unfortunately has no power to change that, but tries to make their use as painless as possible. Please see the README.before.building in meta-crownbay/recipes/xorg-xerver for instructions on the (simple) manual steps necessary to make the necessary binaries available to this recipe. Please do that before building an image."
3
4LICENSE = "Intel-binary-only"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/License.txt;md5=95c4d031b83ab803f3f2401b04ecfbcd"
6PR = "r0"
7
8FILESPATH = "${FILE_DIRNAME}/xserver-xf86-emgd-bin"
9
10FILES_${PN} = "${libdir}/*.so.* ${libdir}/dri ${libdir}/xorg/modules/drivers"
11
12SRC_URI = "file://emgd_dri.so \
13 file://emgd_drv.so \
14 file://emgd_drv_video.so \
15 file://libEGL.so \
16 file://libGLES_CM.so \
17 file://libGLESv2.so \
18 file://libIMGegl.so \
19 file://libOpenVG.so \
20 file://libOpenVGU.so \
21 file://libPVROGL.so \
22 file://libPVRScopeServices.so \
23 file://libXegd_escape.so.2.0.0 \
24 file://libglslcompiler.so \
25 file://libpvr2d.so \
26 file://libpvrPVR2D_DRIWSEGL.so \
27 file://libsrv_init.so \
28 file://libsrv_um.so \
29 file://libva-x11.so.1.0.1 \
30 file://libva.so.1.0.1 \
31 file://License.txt"
32
33S = "${WORKDIR}"
34
35do_install () {
36 install -d -m 0755 ${D}/${libdir}/dri ${D}/${libdir}/xorg/modules/drivers
37
38 install -m 0755 ${S}/emgd_dri.so ${D}${libdir}/dri/emgd_dri.so.1.1.15.3082
39 ln -sf emgd_dri.so.1.1.15.3082 ${D}${libdir}/dri/emgd_dri.so
40
41 install -m 0755 ${S}/emgd_drv.so ${D}${libdir}/xorg/modules/drivers/emgd_drv.so
42 install -m 0755 ${S}/emgd_drv_video.so ${D}${libdir}/xorg/modules/drivers/emgd_drv_video.so
43
44 install -m 0755 ${S}/libEGL.so ${D}${libdir}/libEGL.so.1.1.15.3082
45 ln -sf libEGL.so.1.1.15.3082 ${D}${libdir}/libEGL.so
46
47 install -m 0755 ${S}/libGLES_CM.so ${D}${libdir}/libGLES_CM.so.1.1.15.3082
48 ln -sf libGLES_CM.so.1.1.15.3082 ${D}${libdir}/libGLES_CM.so
49
50 install -m 0755 ${S}/libGLESv2.so ${D}${libdir}/libGLESv2.so.1.1.15.3082
51 ln -sf libGLESv2.so.1.1.15.3082 ${D}${libdir}/libGLESv2.so
52
53 install -m 0755 ${S}/libIMGegl.so ${D}${libdir}/libIMGegl.so.1.1.15.3082
54 ln -sf libIMGegl.so.1.1.15.3082 ${D}${libdir}/libIMGegl.so
55
56 install -m 0755 ${S}/libOpenVG.so ${D}${libdir}/libOpenVG.so.1.1.15.3082
57 ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVG.so
58
59 install -m 0755 ${S}/libOpenVGU.so ${D}${libdir}/libOpenVGU.so.1.1.15.3082
60 ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVGU.so
61
62 install -m 0755 ${S}/libPVROGL.so ${D}${libdir}/libPVROGL.so.1.1.15.3082
63 ln -sf libPVROGL.so.1.1.15.3082 ${D}${libdir}/libPVROGL.so
64
65 install -m 0755 ${S}/libPVRScopeServices.so ${D}${libdir}/libPVRScopeServices.so.1.1.15.3082
66 ln -sf libPVRScopeServices.so.1.1.15.3082 ${D}${libdir}/libPVRScopeServices.so
67
68 install -m 0755 ${S}/libXegd_escape.so.2.0.0 ${D}${libdir}/libXegd_escape.so.2.0.0
69
70 install -m 0755 ${S}/libglslcompiler.so ${D}${libdir}/libglslcompiler.so.1.1.15.3082
71 ln -sf libglslcompiler.so.1.1.15.3082 ${D}${libdir}/libglslcompiler.so
72
73 install -m 0755 ${S}/libpvr2d.so ${D}${libdir}/libpvr2d.so.1.1.15.3082
74 ln -sf libpvr2d.so.1.1.15.3082 ${D}${libdir}/libpvr2d.so
75
76 install -m 0755 ${S}/libpvrPVR2D_DRIWSEGL.so ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so.1.1.15.3082
77 ln -sf libpvrPVR2D_DRIWSEGL.so.1.1.15.3082 ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so
78
79 install -m 0755 ${S}/libsrv_init.so ${D}${libdir}/libsrv_init.so.1.1.15.3082
80 ln -sf libsrv_init.so.1.1.15.3082 ${D}${libdir}/libsrv_init.so
81
82 install -m 0755 ${S}/libsrv_um.so ${D}${libdir}/libsrv_um.so.1.1.15.3082
83 ln -sf libsrv_um.so.1.1.15.3082 ${D}${libdir}/libsrv_um.so
84
85 install -m 0755 ${S}/libva-x11.so.1.0.1 ${D}${libdir}/libva-x11.so.1.0.1
86
87 install -m 0755 ${S}/libva.so.1.0.1 ${D}${libdir}/libva.so.1.0.1
88}
89
90LEAD_SONAME = "libEGL.so"
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch
new file mode 100644
index 00000000..2341e40b
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/crosscompile.patch
@@ -0,0 +1,19 @@
1Index: xorg-server-1.7.99.2/configure.ac
2===================================================================
3--- xorg-server-1.7.99.2.orig/configure.ac 2010-01-29 16:38:49.000000000 +0000
4+++ xorg-server-1.7.99.2/configure.ac 2010-01-29 16:42:39.000000000 +0000
5@@ -503,14 +503,10 @@
6
7 dnl Uses --default-font-path if set, otherwise checks for /etc/X11/fontpath.d,
8 dnl otherwise uses standard subdirectories of FONTROOTDIR
9-AC_CHECK_FILE([${sysconfdir}/X11/fontpath.d],
10- [DEFAULT_FONT_PATH='catalogue:${sysconfdir}/X11/fontpath.d'],
11- [
12 DEFAULT_FONT_PATH="${FONTMISCDIR}/,${FONTTTFDIR}/,${FONTOTFDIR}/,${FONTTYPE1DIR}/,${FONT100DPIDIR}/,${FONT75DPIDIR}/"
13 case $host_os in
14 darwin*) DEFAULT_FONT_PATH="${DEFAULT_FONT_PATH},/Library/Fonts,/System/Library/Fonts" ;;
15 esac
16- ])
17 AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [Comma separated list of font dirs]),
18 [ FONTPATH="$withval" ],
19 [ FONTPATH="${DEFAULT_FONT_PATH}" ])
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch
new file mode 100644
index 00000000..565832ee
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/fix_open_max_preprocessor_error.patch
@@ -0,0 +1,13 @@
1Index: git/os/osdep.h
2===================================================================
3--- git.orig/os/osdep.h 2008-10-07 18:38:21.000000000 +0100
4+++ git/os/osdep.h 2008-10-07 18:39:36.000000000 +0100
5@@ -92,7 +92,7 @@
6 * like sysconf(_SC_OPEN_MAX) is not supported.
7 */
8
9-#if OPEN_MAX <= 256
10+#if 0
11 #define MAXSOCKS (OPEN_MAX - 1)
12 #else
13 #define MAXSOCKS 256
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch
new file mode 100644
index 00000000..6998adff
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/macro_tweak.patch
@@ -0,0 +1,18 @@
1Index: xorg-server-1.5.0/xorg-server.m4
2===================================================================
3--- xorg-server-1.5.0.orig/xorg-server.m4 2007-05-29 20:36:51.000000000 +0100
4+++ xorg-server-1.5.0/xorg-server.m4 2008-11-04 23:56:55.000000000 +0000
5@@ -28,9 +28,12 @@
6 # Checks for the $1 define in xorg-server.h (from the sdk). If it
7 # is defined, then add $1 to $REQUIRED_MODULES.
8
9+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
10+
11 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
12+ PKG_PROG_PKG_CONFIG
13 SAVE_CFLAGS="$CFLAGS"
14- CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`"
15+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`pkg-config --variable=sdkdir xorg-server`"
16 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
17 #include "xorg-server.h"
18 #if !defined $1
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch
new file mode 100644
index 00000000..6b34032a
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd/nodolt.patch
@@ -0,0 +1,12 @@
1Index: git/configure.ac
2===================================================================
3--- git.orig/configure.ac 2009-01-15 20:35:31.000000000 +0000
4+++ git/configure.ac 2009-01-15 20:35:38.000000000 +0000
5@@ -62,7 +62,6 @@
6 AC_LIBTOOL_WIN32_DLL
7 AC_DISABLE_STATIC
8 AC_PROG_LIBTOOL
9-DOLT
10 AC_PROG_MAKE_SET
11 PKG_PROG_PKG_CONFIG
12 AC_PROG_LEX
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb
new file mode 100644
index 00000000..5f22213a
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd_1.7.99.2.bb
@@ -0,0 +1,25 @@
1require recipes-graphics/xorg-xserver/xserver-xf86-dri-lite.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=3dd2bbe3563837f80ed8926b06c1c353"
4
5PROTO_DEPS += "xf86driproto dri2proto"
6
7DEPENDS += "font-util"
8
9PE = "1"
10PR = "r0"
11
12SRC_URI += "file://nodolt.patch \
13 file://crosscompile.patch"
14
15# Misc build failure for master HEAD
16SRC_URI += "file://fix_open_max_preprocessor_error.patch"
17
18SRC_URI[md5sum] = "5c8773499a6a8c1ddaedf33577ec9634"
19SRC_URI[sha256sum] = "8b30800004c98fc7a8e6ff31a339f28451be5132e774443be22bf226e1791e34"
20
21RDEPENDS_${PN} += "xserver-xf86-emgd-bin mesa-dri"
22
23COMPATIBLE_MACHINE = "crownbay"
24
25EXTRA_OECONF += "--enable-dga --enable-dri --enable-dri2"