summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-13 22:40:15 -0600
committerSaul Wold <sgw@linux.intel.com>2011-01-03 16:45:27 -0800
commit7059fe6442b0cf480261fbcdea3e5ba404afef27 (patch)
tree229efc2453e72560d5d89551753d388f36fb2c61 /meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
parentc14f24a2e9aebaaf2edb005f9480b395a8618acf (diff)
downloadmeta-intel-7059fe6442b0cf480261fbcdea3e5ba404afef27.tar.gz
meta-crownbay: new layer for E6xx/EG20T systems
This layer provides support for Tunnel Creek + Topcliff Intel systems to laverne (0.90). It supports the E6xx embedded on-chip graphics via the Intel Embedded Media and Graphics Driver (EMGD) 1.5 Gold Driver. The EMGD and EG20T PCH kernel drivers are of course GPL'ed and are submitted in a separate patchset for the 2.6.34 yocto kernel. The userspace X drivers and supporting libraries however are closed and need to be manually copied into the layer before building. The details on how to do this can be found in the README doc in meta-crownbay/. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb')
-rw-r--r--meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
new file mode 100644
index 00000000..95068722
--- /dev/null
+++ b/meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-emgd-bin_1.7.99.2.bb
@@ -0,0 +1,90 @@
1SUMMARY = "EMGD 1.5 xserver binaries"
2DESCRIPTION = "EMGD 1.5 includes some userspace binaries that use non-free licensing. Intel Open Source Technology Center unfortunately has no power to change that, but tries to make their use as painless as possible. Please see the README.before.building in meta-crownbay/recipes/xorg-xerver for instructions on the (simple) manual steps necessary to make the necessary binaries available to this recipe. Please do that before building an image."
3
4LICENSE = "Intel-binary-only"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/License.txt;md5=95c4d031b83ab803f3f2401b04ecfbcd"
6PR = "r0"
7
8FILESPATH = "${FILE_DIRNAME}/xserver-xf86-emgd-bin"
9
10FILES_${PN} = "${libdir}/*.so.* ${libdir}/dri ${libdir}/xorg/modules/drivers"
11
12SRC_URI = "file://emgd_dri.so \
13 file://emgd_drv.so \
14 file://emgd_drv_video.so \
15 file://libEGL.so \
16 file://libGLES_CM.so \
17 file://libGLESv2.so \
18 file://libIMGegl.so \
19 file://libOpenVG.so \
20 file://libOpenVGU.so \
21 file://libPVROGL.so \
22 file://libPVRScopeServices.so \
23 file://libXegd_escape.so.2.0.0 \
24 file://libglslcompiler.so \
25 file://libpvr2d.so \
26 file://libpvrPVR2D_DRIWSEGL.so \
27 file://libsrv_init.so \
28 file://libsrv_um.so \
29 file://libva-x11.so.1.0.1 \
30 file://libva.so.1.0.1 \
31 file://License.txt"
32
33S = "${WORKDIR}"
34
35do_install () {
36 install -d -m 0755 ${D}/${libdir}/dri ${D}/${libdir}/xorg/modules/drivers
37
38 install -m 0755 ${S}/emgd_dri.so ${D}${libdir}/dri/emgd_dri.so.1.1.15.3082
39 ln -sf emgd_dri.so.1.1.15.3082 ${D}${libdir}/dri/emgd_dri.so
40
41 install -m 0755 ${S}/emgd_drv.so ${D}${libdir}/xorg/modules/drivers/emgd_drv.so
42 install -m 0755 ${S}/emgd_drv_video.so ${D}${libdir}/xorg/modules/drivers/emgd_drv_video.so
43
44 install -m 0755 ${S}/libEGL.so ${D}${libdir}/libEGL.so.1.1.15.3082
45 ln -sf libEGL.so.1.1.15.3082 ${D}${libdir}/libEGL.so
46
47 install -m 0755 ${S}/libGLES_CM.so ${D}${libdir}/libGLES_CM.so.1.1.15.3082
48 ln -sf libGLES_CM.so.1.1.15.3082 ${D}${libdir}/libGLES_CM.so
49
50 install -m 0755 ${S}/libGLESv2.so ${D}${libdir}/libGLESv2.so.1.1.15.3082
51 ln -sf libGLESv2.so.1.1.15.3082 ${D}${libdir}/libGLESv2.so
52
53 install -m 0755 ${S}/libIMGegl.so ${D}${libdir}/libIMGegl.so.1.1.15.3082
54 ln -sf libIMGegl.so.1.1.15.3082 ${D}${libdir}/libIMGegl.so
55
56 install -m 0755 ${S}/libOpenVG.so ${D}${libdir}/libOpenVG.so.1.1.15.3082
57 ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVG.so
58
59 install -m 0755 ${S}/libOpenVGU.so ${D}${libdir}/libOpenVGU.so.1.1.15.3082
60 ln -sf libOpenVG.so.1.1.15.3082 ${D}${libdir}/libOpenVGU.so
61
62 install -m 0755 ${S}/libPVROGL.so ${D}${libdir}/libPVROGL.so.1.1.15.3082
63 ln -sf libPVROGL.so.1.1.15.3082 ${D}${libdir}/libPVROGL.so
64
65 install -m 0755 ${S}/libPVRScopeServices.so ${D}${libdir}/libPVRScopeServices.so.1.1.15.3082
66 ln -sf libPVRScopeServices.so.1.1.15.3082 ${D}${libdir}/libPVRScopeServices.so
67
68 install -m 0755 ${S}/libXegd_escape.so.2.0.0 ${D}${libdir}/libXegd_escape.so.2.0.0
69
70 install -m 0755 ${S}/libglslcompiler.so ${D}${libdir}/libglslcompiler.so.1.1.15.3082
71 ln -sf libglslcompiler.so.1.1.15.3082 ${D}${libdir}/libglslcompiler.so
72
73 install -m 0755 ${S}/libpvr2d.so ${D}${libdir}/libpvr2d.so.1.1.15.3082
74 ln -sf libpvr2d.so.1.1.15.3082 ${D}${libdir}/libpvr2d.so
75
76 install -m 0755 ${S}/libpvrPVR2D_DRIWSEGL.so ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so.1.1.15.3082
77 ln -sf libpvrPVR2D_DRIWSEGL.so.1.1.15.3082 ${D}${libdir}/libpvrPVR2D_DRIWSEGL.so
78
79 install -m 0755 ${S}/libsrv_init.so ${D}${libdir}/libsrv_init.so.1.1.15.3082
80 ln -sf libsrv_init.so.1.1.15.3082 ${D}${libdir}/libsrv_init.so
81
82 install -m 0755 ${S}/libsrv_um.so ${D}${libdir}/libsrv_um.so.1.1.15.3082
83 ln -sf libsrv_um.so.1.1.15.3082 ${D}${libdir}/libsrv_um.so
84
85 install -m 0755 ${S}/libva-x11.so.1.0.1 ${D}${libdir}/libva-x11.so.1.0.1
86
87 install -m 0755 ${S}/libva.so.1.0.1 ${D}${libdir}/libva.so.1.0.1
88}
89
90LEAD_SONAME = "libEGL.so"