summaryrefslogtreecommitdiffstats
path: root/meta-chiefriver
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2014-03-12 12:12:32 -0700
committerTom Zanussi <tom.zanussi@intel.com>2014-03-26 22:41:49 -0500
commit8d79fb4e0cec07fe05ca440578414eaa6be80a3a (patch)
tree067a7cc91fcd612e9d9797900378970f010f838f /meta-chiefriver
parenta1491bc54b60a1c622a9060756fd9b145bc01378 (diff)
downloadmeta-intel-8d79fb4e0cec07fe05ca440578414eaa6be80a3a.tar.gz
Remove chiefriver, sys940x & n450 BSPs
Configuration for the chiefriver, sys940x, sys940x-noemgd, n450 BSPs are deleted. The consolidated BSPs viz intel-corei7-64 and intel-core2-32 support these boards. As part of the usual retirement process, a heads-up email was sent to the meta-intel mailing list requesting any feedback regarding retirement of these BSPs. The community did not had any concerning feedback to reconsider the retirement decision. The MAINTAINERS file and the layer version of the meta-intel layer are updated to reflect removal of the BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> CC: Darren Hart <dvhart@linux.intel.com> Reviewed-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-chiefriver')
-rw-r--r--meta-chiefriver/COPYING.MIT17
-rw-r--r--meta-chiefriver/README158
-rw-r--r--meta-chiefriver/README.sources17
-rw-r--r--meta-chiefriver/conf/layer.conf10
-rw-r--r--meta-chiefriver/conf/machine/chiefriver.conf21
-rw-r--r--meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig3
-rw-r--r--meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-chiefriver/recipes-kernel/linux/linux-yocto-dev.bbappend11
-rw-r--r--meta-chiefriver/recipes-kernel/linux/linux-yocto_3.10.bbappend13
9 files changed, 0 insertions, 251 deletions
diff --git a/meta-chiefriver/COPYING.MIT b/meta-chiefriver/COPYING.MIT
deleted file mode 100644
index fb950dc6..00000000
--- a/meta-chiefriver/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-chiefriver/README b/meta-chiefriver/README
deleted file mode 100644
index f846be6b..00000000
--- a/meta-chiefriver/README
+++ /dev/null
@@ -1,158 +0,0 @@
1This README file contains information on building the meta-chiefriver
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'Chief River' platform consists of the Intel Ivy Bridge processor,
6plus the Panther Point PCH. This BSP assumes that the Ivy Bridge
7integrated graphics are being used.
8
9Further information on the platforms supported by this BSP can be
10found here:
11
12 http://www.intel.com/p/en_US/embedded/hwsw/hardware/core-hm76/overview
13
14Information on all IntelĀ® embedded platforms can be found here:
15
16 http://www.intel.com/p/en_US/embedded/hwsw/hardware
17
18
19Yocto Project Compatible
20========================
21
22This BSP is compatible with the Yocto Project as per the requirements
23listed here:
24
25 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
26
27
28Dependencies
29============
30
31This layer depends on:
32
33 URI: git://git.openembedded.org/bitbake
34 branch: master
35
36 URI: git://git.openembedded.org/openembedded-core
37 layers: meta
38 branch: master
39
40 URI: git://git.yoctoproject.org/meta-intel
41 layers: intel
42 branch: master
43
44
45Patches
46=======
47
48Please submit any patches against this BSP to the Yocto mailing list
49(yocto@yoctoproject.org) and cc: the maintainer:
50
51Maintainer: Nitin A Kamble <nitin.a.kamble@intel.com>
52
53Please see the meta-intel/MAINTAINERS file for more details.
54
55
56Table of Contents
57=================
58
59 I. Building the meta-chiefriver BSP layer
60 II. Booting the images in /binary
61
62
63I. Building the meta-chiefriver BSP layer
64=========================================
65
66In order to build an image with BSP support for a given release, you
67need to download the corresponding BSP tarball from the 'Board Support
68Package (BSP) Downloads' page of the Yocto Project website.
69
70Having done that, and assuming you extracted the BSP tarball contents
71at the top-level of your yocto build tree, you can build a chiefriver
72image by adding the location of the meta-chiefriver layer to
73bblayers.conf, along with the meta-intel layer itself (to access
74common metadata shared between BSPs) e.g.:
75
76 yocto/meta-intel \
77 yocto/meta-intel/meta-chiefriver \
78
79To enable the chiefriver layer, add the chiefriver MACHINE to local.conf:
80
81 MACHINE ?= "chiefriver"
82
83You should then be able to build a chiefriver image as such:
84
85 $ source oe-init-build-env
86 $ bitbake core-image-sato
87
88At the end of a successful build, you should have a live image that
89you can boot from a USB flash drive (see instructions on how to do
90that below, in the section 'Booting the images from /binary').
91
92NOTE: The 'chiefriver' machine will include support for hardware video
93acceleration via gstreamer if and only if the "commercial" string is
94added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
95
96For example:
97
98 LICENSE_FLAGS_WHITELIST = "commercial"
99
100The reason this is needed is to prevent the image from including
101anything that might violate the license terms of the packages used to
102implement the the video acceleration feature, such as gst-ffmpeg and
103ffmpeg. As always, please consult the licenses included in the
104specific packages for details if you use packages that require
105particular LICENSE_FLAGS.
106
107The xf86-video-intel recipe depends on Xorg's dri and glx modules,
108which are built only when 'opengl' is listed in DISTRO_FEATURES. So
109if the distro doesn't list 'opengl' in the DISTRO_FEATURES, then you
110would need this additional line in your local.conf:
111
112 DISTRO_FEATURES_append = " opengl"
113
114As an alternative to downloading the BSP tarball, you can also work
115directly from the meta-intel git repository. For each BSP in the
116'meta-intel' repository, there are multiple branches, one
117corresponding to each major release starting with 'laverne' (0.90), in
118addition to the latest code which tracks the current master (note that
119not all BSPs are present in every release). Instead of extracting a
120BSP tarball at the top level of your yocto build tree, you can
121equivalently check out the appropriate branch from the meta-intel
122repository at the same location.
123
124
125II. Booting the images in /binary
126=================================
127
128This BSP contains bootable live images, which can be used to directly
129boot Yocto off of a USB flash drive.
130
131Under Linux, insert a USB flash drive. Assuming the USB flash drive
132takes device /dev/sdf, use dd to copy the live image to it. For
133example:
134
135# dd if=core-image-sato-chiefriver.hddimg of=/dev/sdf
136# sync
137# eject /dev/sdf
138
139This should give you a bootable USB flash device. Insert the device
140into a bootable USB socket on the target, and power on. This should
141result in a system booted to the Sato graphical desktop.
142
143If you want a terminal, use the arrows at the top of the UI to move to
144different pages of available applications, one of which is named
145'Terminal'. Clicking that should give you a root terminal.
146
147If you want to ssh into the system, you can use the root terminal to
148ifconfig the IP address and use that to ssh in. The root password is
149empty, so to log in type 'root' for the user name and hit 'Enter' at
150the Password prompt: and you should be in.
151
152----
153
154If you find you're getting corrupt images on the USB (it doesn't show
155the syslinux boot: prompt, or the boot: prompt contains strange
156characters), try doing this first:
157
158# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-chiefriver/README.sources b/meta-chiefriver/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-chiefriver/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-chiefriver/conf/layer.conf b/meta-chiefriver/conf/layer.conf
deleted file mode 100644
index 6164f995..00000000
--- a/meta-chiefriver/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "chiefriver"
9BBFILE_PATTERN_chiefriver := "^${LAYERDIR}/"
10BBFILE_PRIORITY_chiefriver = "6"
diff --git a/meta-chiefriver/conf/machine/chiefriver.conf b/meta-chiefriver/conf/machine/chiefriver.conf
deleted file mode 100644
index 89a2afcc..00000000
--- a/meta-chiefriver/conf/machine/chiefriver.conf
+++ /dev/null
@@ -1,21 +0,0 @@
1#@TYPE: Machine
2#@NAME: chiefriver
3
4#@WEBTITLE: Intel 3rd Generation Core Platforms: Core i3, i5, i7 (Ivy Bridge)
5
6#@DESCRIPTION: Machine configuration for Chief River systems
7# i.e. Ivy Bridge + Panther Point
8
9PREFERRED_VERSION_linux-yocto ?= "3.10%"
10MACHINE_FEATURES += "va-impl-intel"
11
12require conf/machine/include/intel-corei7-64-common.inc
13
14MACHINE_HWCODECS ?= "va-intel gst-va-intel"
15
16XSERVER ?= "${XSERVER_X86_BASE} \
17 ${XSERVER_X86_EXT} \
18 ${XSERVER_X86_I965} \
19 "
20
21MACHINE_EXTRA_RRECOMMENDS += "lms7"
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig b/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto-dev.bbappend
deleted file mode 100644
index a370cbd9..00000000
--- a/meta-chiefriver/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ /dev/null
@@ -1,11 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_chiefriver = "chiefriver"
5KMACHINE_chiefriver = "chiefriver"
6KBRANCH_chiefriver = "standard/common-pc-64/chiefriver"
7
8KERNEL_FEATURES_append_chiefriver = " features/amt/mei"
9
10SRCREV_machine_chiefriver = "60536206ad300ccf5b2be2c2d449f4ab27170238"
11SRCREV_meta_chiefriver = "fe20c99783387dab779472ff50a88666da1c6391"
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 000f5d1d..00000000
--- a/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4COMPATIBLE_MACHINE_chiefriver = "chiefriver"
5KMACHINE_chiefriver = "chiefriver"
6KBRANCH_chiefriver = "standard/common-pc-64/chiefriver"
7
8KERNEL_FEATURES_append_chiefriver = " features/amt/mei/mei.scc"
9
10LINUX_VERSION = "3.10.19"
11
12SRCREV_meta_chiefriver = "d9cd83c0292bd4e2a6754a96761027252e726a42"
13SRCREV_machine_chiefriver = "a9ec82e355130160f9094e670bd5be0022a84194"