summaryrefslogtreecommitdiffstats
path: root/meta-chiefriver
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-05-17 22:17:42 -0500
committerTom Zanussi <tom.zanussi@intel.com>2012-05-30 14:22:51 -0500
commit37dee2e3ea78746be32057074ead9f9de5124670 (patch)
treecd9e503d72b8013cb4c3a6579b239517037fb58f /meta-chiefriver
parentc05129498c4f3b1757ce0ee195d6ff1d3f71c5d5 (diff)
downloadmeta-intel-37dee2e3ea78746be32057074ead9f9de5124670.tar.gz
meta-chiefriver: new layer for Chief River (Ivy Bridge/Panther Point) systems
This layer provides support for Ivy Bridge + Panther Point Intel systems. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-chiefriver')
-rw-r--r--meta-chiefriver/COPYING.MIT17
-rw-r--r--meta-chiefriver/README107
-rw-r--r--meta-chiefriver/README.sources17
-rw-r--r--meta-chiefriver/conf/layer.conf10
-rw-r--r--meta-chiefriver/conf/machine/chiefriver.conf15
-rw-r--r--meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig3
-rw-r--r--meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend3
-rw-r--r--meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend2
-rw-r--r--meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf26
-rw-r--r--meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend3
-rw-r--r--meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend8
-rw-r--r--meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend8
12 files changed, 219 insertions, 0 deletions
diff --git a/meta-chiefriver/COPYING.MIT b/meta-chiefriver/COPYING.MIT
new file mode 100644
index 00000000..fb950dc6
--- /dev/null
+++ b/meta-chiefriver/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-chiefriver/README b/meta-chiefriver/README
new file mode 100644
index 00000000..49e44613
--- /dev/null
+++ b/meta-chiefriver/README
@@ -0,0 +1,107 @@
1This README file contains information on building the meta-chiefriver
2BSP layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'Chief River' platform consists of the Intel Ivy Bridge processor,
6plus the Panther Point PCH. This BSP assumes that the Ivy Bridge
7integrated graphics are being used.
8
9
10Dependencies
11============
12
13This layer depends on:
14
15 URI: git://git.openembedded.org/bitbake
16 branch: master
17
18 URI: git://git.openembedded.org/openembedded-core
19 layers: meta
20 branch: master
21
22 URI: git://git.yoctoproject.org/meta-intel
23 layers: intel
24 branch: master
25
26
27Table of Contents
28=================
29
30 I. Building the meta-chiefriver BSP layer
31 II. Booting the images in /binary
32
33
34I. Building the meta-chiefriver BSP layer
35=========================================
36
37In order to build an image with BSP support for a given release, you
38need to download the corresponding BSP tarball from the 'Board Support
39Package (BSP) Downloads' page of the Yocto Project website.
40
41Having done that, and assuming you extracted the BSP tarball contents
42at the top-level of your yocto build tree, you can build a chiefriver
43image by adding the location of the meta-chiefriver layer to
44bblayers.conf, along with the meta-intel layer itself (to access
45common metadata shared between BSPs) e.g.:
46
47 yocto/meta-intel \
48 yocto/meta-intel/meta-chiefriver \
49
50To enable the chiefriver layer, add the chiefriver MACHINE to local.conf:
51
52 MACHINE ?= "chiefriver"
53
54You should then be able to build a chiefriver image as such:
55
56 $ source oe-init-build-env
57 $ bitbake core-image-sato
58
59At the end of a successful build, you should have a live image that
60you can boot from a USB flash drive (see instructions on how to do
61that below, in the section 'Booting the images from /binary').
62
63As an alternative to downloading the BSP tarball, you can also work
64directly from the meta-intel git repository. For each BSP in the
65'meta-intel' repository, there are multiple branches, one
66corresponding to each major release starting with 'laverne' (0.90), in
67addition to the latest code which tracks the current master (note that
68not all BSPs are present in every release). Instead of extracting a
69BSP tarball at the top level of your yocto build tree, you can
70equivalently check out the appropriate branch from the meta-intel
71repository at the same location.
72
73
74II. Booting the images in /binary
75=================================
76
77This BSP contains bootable live images, which can be used to directly
78boot Yocto off of a USB flash drive.
79
80Under Linux, insert a USB flash drive. Assuming the USB flash drive
81takes device /dev/sdf, use dd to copy the live image to it. For
82example:
83
84# dd if=core-image-sato-chiefriver-20101207053738.hddimg of=/dev/sdf
85# sync
86# eject /dev/sdf
87
88This should give you a bootable USB flash device. Insert the device
89into a bootable USB socket on the target, and power on. This should
90result in a system booted to the Sato graphical desktop.
91
92If you want a terminal, use the arrows at the top of the UI to move to
93different pages of available applications, one of which is named
94'Terminal'. Clicking that should give you a root terminal.
95
96If you want to ssh into the system, you can use the root terminal to
97ifconfig the IP address and use that to ssh in. The root password is
98empty, so to log in type 'root' for the user name and hit 'Enter' at
99the Password prompt: and you should be in.
100
101----
102
103If you find you're getting corrupt images on the USB (it doesn't show
104the syslinux boot: prompt, or the boot: prompt contains strange
105characters), try doing this first:
106
107# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-chiefriver/README.sources b/meta-chiefriver/README.sources
new file mode 100644
index 00000000..76180f1a
--- /dev/null
+++ b/meta-chiefriver/README.sources
@@ -0,0 +1,17 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://www.yoctoproject.org/downloads/yocto-1.2/poky-denzil-7.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-chiefriver/conf/layer.conf b/meta-chiefriver/conf/layer.conf
new file mode 100644
index 00000000..5dc3c021
--- /dev/null
+++ b/meta-chiefriver/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "chiefriver"
9BBFILE_PATTERN_chiefriver := "^${LAYERDIR}/"
10BBFILE_PRIORITY_chiefriver = "6"
diff --git a/meta-chiefriver/conf/machine/chiefriver.conf b/meta-chiefriver/conf/machine/chiefriver.conf
new file mode 100644
index 00000000..c9237f41
--- /dev/null
+++ b/meta-chiefriver/conf/machine/chiefriver.conf
@@ -0,0 +1,15 @@
1#@TYPE: Machine
2#@NAME: chiefriver
3
4#@DESCRIPTION: Machine configuration for Chief River systems
5# i.e. Ivy Bridge + Panther Point
6
7PREFERRED_VERSION_linux-yocto ?= "3.2%"
8
9require conf/machine/include/tune-x86_64.inc
10require conf/machine/include/ia32-base.inc
11
12XSERVER ?= "${XSERVER_IA32_BASE} \
13 ${XSERVER_IA32_EXT} \
14 ${XSERVER_IA32_I965} \
15 "
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig b/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig
new file mode 100644
index 00000000..ffce0122
--- /dev/null
+++ b/meta-chiefriver/recipes-bsp/formfactor/formfactor/chiefriver/machconfig
@@ -0,0 +1,3 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 00000000..54da0ffd
--- /dev/null
+++ b/meta-chiefriver/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC = "1"
diff --git a/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend b/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend
new file mode 100644
index 00000000..4631da3f
--- /dev/null
+++ b/meta-chiefriver/recipes-core/tasks/task-core-tools-profile.bbappend
@@ -0,0 +1,2 @@
1RRECOMMENDS_task-core-tools-profile_append_chiefriver = " systemtap"
2
diff --git a/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf
new file mode 100644
index 00000000..96b94b46
--- /dev/null
+++ b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config/chiefriver/xorg.conf
@@ -0,0 +1,26 @@
1Section "Device"
2 Identifier "Intel Graphics Driver"
3 Driver "intel"
4EndSection
5
6Section "Monitor"
7 Identifier "Generic Monitor"
8 Option "DPMS"
9EndSection
10
11Section "Screen"
12 Identifier "Default Screen"
13 Device "Intel Graphics Driver"
14 Monitor "Generic Monitor"
15 DefaultDepth 24
16EndSection
17
18Section "ServerLayout"
19 Identifier "Default Layout"
20 Screen "Default Screen"
21EndSection
22
23Section "ServerFlags"
24 Option "DontZap" "0"
25 Option "AutoAddDevices" "False"
26EndSection
diff --git a/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
new file mode 100644
index 00000000..4b8d0e65
--- /dev/null
+++ b/meta-chiefriver/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -0,0 +1,3 @@
1THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
3
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
new file mode 100644
index 00000000..9e4a4a07
--- /dev/null
+++ b/meta-chiefriver/recipes-kernel/linux/linux-yocto-rt_3.2.bbappend
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2COMPATIBLE_MACHINE_chiefriver = "chiefriver"
3KMACHINE_chiefriver = "chiefriver"
4
5# Update the following to use a different BSP branch or meta SRCREV
6#KBRANCH_chiefriver = "standard/preempt-rt/base"
7#SRCREV_machine_pn-linux-yocto-rt_chiefriver ?= XXXX
8#SRCREV_meta_pn-linux-yocto-rt_chiefriver ?= XXXX
diff --git a/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend b/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend
new file mode 100644
index 00000000..0b707bed
--- /dev/null
+++ b/meta-chiefriver/recipes-kernel/linux/linux-yocto_3.2.bbappend
@@ -0,0 +1,8 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3COMPATIBLE_MACHINE_chiefriver = "chiefriver"
4KMACHINE_chiefriver = "chiefriver"
5KBRANCH_chiefriver = "standard/default/common-pc-64/chiefriver"
6
7SRCREV_machine_pn-linux-yocto_chiefriver ?= "dbe820c277dfa6cbc249d410e8b083286ec484b7"
8SRCREV_meta_pn-linux-yocto_chiefriver ?= "353d43d340e87996b4be4c5f6ddb4447e050b65c"