summaryrefslogtreecommitdiffstats
path: root/meta-cedartrail
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2012-10-17 10:56:35 +0100
committerTom Zanussi <tom.zanussi@intel.com>2012-11-06 18:09:01 -0600
commit606f2a87999c5fe5131879ca343c74c3df298892 (patch)
tree5787c81ff25f004ff89fce492d80174a12395951 /meta-cedartrail
parentb5610a7fd40812c1e08c12658d511647bb008fa6 (diff)
downloadmeta-intel-606f2a87999c5fe5131879ca343c74c3df298892.tar.gz
cdv-pvr-driver: add xorg-abi-video- dependency
xserver changes the driver ABI at will, and refuses to load drivers with the wrong ABI version. So that we know about this error at image build time instead of when xserver fails to start, RDEPEND on the ABI version we expect. This dependency is added programmatically so that bitbake doesn't look for a provider of xorg-abi-video-8 at parse time, which it won't find. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-cedartrail')
-rw-r--r--meta-cedartrail/recipes-graphics/xorg-driver/cdv-pvr-driver_1.0.3.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-cedartrail/recipes-graphics/xorg-driver/cdv-pvr-driver_1.0.3.bb b/meta-cedartrail/recipes-graphics/xorg-driver/cdv-pvr-driver_1.0.3.bb
index 7bda3b50..ebb58911 100644
--- a/meta-cedartrail/recipes-graphics/xorg-driver/cdv-pvr-driver_1.0.3.bb
+++ b/meta-cedartrail/recipes-graphics/xorg-driver/cdv-pvr-driver_1.0.3.bb
@@ -88,6 +88,15 @@ FILES_${PN} += "${datadir}/doc/pvr-bin-cdv-${PVR-BIN-REV_LIC}/license.txt"
88 88
89RDEPENDS_${PN} = "xserver-xorg-module-exa" 89RDEPENDS_${PN} = "xserver-xorg-module-exa"
90 90
91# Add the ABI dependency at package generation time, as otherwise bitbake will
92# attempt to find a provider for it (and fail) when it does the parse.
93#
94# This version *must* be kept correct.
95python populate_packages_prepend() {
96 pn = d.getVar("PN", True)
97 d.appendVar("RDEPENDS_" + pn, " xorg-abi-video-8")
98}
99
91TARGET_CC_ARCH += "${CFLAGS}{LDFLAGS}" 100TARGET_CC_ARCH += "${CFLAGS}{LDFLAGS}"
92INSANE_SKIP_${PN} += "ldflags" 101INSANE_SKIP_${PN} += "ldflags"
93INSANE_SKIP_${PN}-dbg += "ldflags" 102INSANE_SKIP_${PN}-dbg += "ldflags"