summaryrefslogtreecommitdiffstats
path: root/meta-cedartrail/conf
diff options
context:
space:
mode:
authorRahul Saxena <rahul.saxena@intel.com>2011-12-15 07:30:47 -0800
committerTom Zanussi <tom.zanussi@intel.com>2011-12-16 17:03:47 -0600
commit454d5fc30e912aa8b5af07e08e42e68e17d74213 (patch)
tree42707766377ecdb2dcceb0bbbcb41420bf70226a /meta-cedartrail/conf
parent10e3a043fbc6abcf4b1f5b464c2df5a6d957cf97 (diff)
downloadmeta-intel-454d5fc30e912aa8b5af07e08e42e68e17d74213.tar.gz
meta-cedartrail: new layer for Cedar Trail Systems
This layer provides the initial version of the BSP for Cedar Trail platform. The Cedar Trail platform is based on the Cedarview processor and Tiger Point Chipset. Signed-off-by: Rahul Saxena <rahul.saxena@.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@.intel.com>
Diffstat (limited to 'meta-cedartrail/conf')
-rwxr-xr-xmeta-cedartrail/conf/layer.conf10
-rwxr-xr-xmeta-cedartrail/conf/machine/cedartrail.conf38
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-cedartrail/conf/layer.conf b/meta-cedartrail/conf/layer.conf
new file mode 100755
index 00000000..cb4142d0
--- /dev/null
+++ b/meta-cedartrail/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "cedartrail"
9BBFILE_PATTERN_cedartrail := "^${LAYERDIR}/"
10BBFILE_PRIORITY_cedartrail = "6"
diff --git a/meta-cedartrail/conf/machine/cedartrail.conf b/meta-cedartrail/conf/machine/cedartrail.conf
new file mode 100755
index 00000000..23ee0a7b
--- /dev/null
+++ b/meta-cedartrail/conf/machine/cedartrail.conf
@@ -0,0 +1,38 @@
1#@TYPE: Machine
2#@NAME: Cedartrail
3
4#@DESCRIPTION: Machine configuration for Cedartrail systems
5# i.e. Cedarview processor + Tiger Point Chipset
6
7include conf/machine/include/tune-atom.inc
8
9MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
10 acpi serial usbgadget"
11
12KERNEL_IMAGETYPE = "bzImage"
13
14PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
15PREFERRED_VERSION_linux-yocto ?= "3.0%"
16
17PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
18PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
19PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
20PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
21PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
22XSERVER ?= "xserver-xf86-dri-lite \
23 xf86-input-mouse \
24 xf86-input-keyboard \
25 xf86-input-evdev \
26 xf86-input-synaptics \
27 xf86-video-vesa"
28
29SERIAL_CONSOLE = "115200 ttyS3"
30
31MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts"
32
33IMAGE_FSTYPES ?= "ext3 cpio.gz live"
34
35GLIBC_ADDONS = "nptl"
36GLIBC_EXTRA_OECONF = "--with-tls"
37
38MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "grub"