summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-05-28 17:53:25 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-05-28 19:02:57 +0800
commit8e1c5395e85921350ff40564edf035faacd98e3d (patch)
treee8a5c8a1755ef7dc394e9fe731e48246aa83c782 /dynamic-layers
parent281f03435efa663ecbf3e546c316d11dee5d8055 (diff)
downloadmeta-intel-8e1c5395e85921350ff40564edf035faacd98e3d.tar.gz
intel-graphics-compiler: upgrade 1.0.3771 -> 1.0.4053
Release notes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.4053 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch39
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4053.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb)3
2 files changed, 41 insertions, 1 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch
new file mode 100644
index 00000000..ae8ccbf2
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-add-workaround-for-gcc-10-error.patch
@@ -0,0 +1,39 @@
1From 8435bfb432282bdb900492f479233d2772f57f7c Mon Sep 17 00:00:00 2001
2From: 8tab <tab.debugteam@gmail.com>
3Date: Thu, 21 May 2020 14:21:58 +0200
4Subject: [PATCH] Add workaround for gcc 10 internal compiler error
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9There is a regression in recent gcc (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95241),
10that make IGC fail to compile:
11In file included from /home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/Models.cpp:7:
12/home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/bxml/Model7P5.hpp:1258:34: in ‘constexpr’ expansion of ‘iga::Field(((const char*)"MathFC"), 24, 4)’
13/home/tab/dev/external/oneapi/igc/visa/iga/IGALibrary/Models/bxml/Model7P5.hpp:2085:5: internal compiler error: in tree_to_uhwi, at tree.h:4519
14 2085 | };
15 | ^
16
17Upstream-Status: Submitted [https://github.com/intel/intel-graphics-compiler/pull/135]
18Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
19---
20 visa/iga/IGALibrary/Backend/Native/Field.hpp | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/visa/iga/IGALibrary/Backend/Native/Field.hpp b/visa/iga/IGALibrary/Backend/Native/Field.hpp
24index 4b97280b..04855576 100644
25--- a/visa/iga/IGALibrary/Backend/Native/Field.hpp
26+++ b/visa/iga/IGALibrary/Backend/Native/Field.hpp
27@@ -150,8 +150,8 @@ namespace iga
28 // a simple encoded field (single contiguous)
29 constexpr Field(const char *_name, int offset, int length)
30 : name(_name)
31- , fragments{Fragment(_name, offset, length)}
32 {
33+ fragments[0] = Fragment(_name, offset, length);
34 }
35 // a zero fill field or must-be-zero field
36 constexpr Field(const char *_name, int length,
37--
382.17.1
39
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4053.bb
index 93484c47..11fb2b87 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.3771.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.4053.bb
@@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc
9 9
10SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \ 10SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
11 file://0001-skip-execution-of-ElfPackager.patch \ 11 file://0001-skip-execution-of-ElfPackager.patch \
12 file://0001-add-workaround-for-gcc-10-error.patch \
12 " 13 "
13 14
14SRCREV = "577887bf74c51a6084058836720fe58f8c35ca58" 15SRCREV = "bd171d27a65dd82a0966f54f012b113e2796d87e"
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
17 18