summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2019-09-11 22:00:04 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2019-09-24 10:24:42 +0800
commit7aef51c962c023f27e3fcda4c2419f1ced9942b9 (patch)
tree3467940f052b4a8c154e18af31dd80ff99b85397 /dynamic-layers
parent70d414ce566d07f1fe09ccf7e945ce42c1e73dd9 (diff)
downloadmeta-intel-7aef51c962c023f27e3fcda4c2419f1ced9942b9.tar.gz
dldt-model-optimizer: add recipe
Model Optimizer is a cross-platform command-line tool that facilitates the transition between the training and deployment environment, performs static model analysis, and adjusts deep learning models for optimal execution on end-point target devices. For more details, see: https://software.intel.com/en-us/openvino-toolkit/deep-learning-cv Since the recipe requires bits from meta-python, move this to the dynamic layers section and add meta-python to BBFILES_DYNAMIC. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb
new file mode 100644
index 00000000..0a622ca6
--- /dev/null
+++ b/dynamic-layers/meta-python/recipes-opencv/dldt/dldt-model-optimizer_2019r2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "OpenVINO Model Optimzer"
2DESCRIPTION = "Model Optimizer is a cross-platform command-line tool that \
3facilitates the transition between the training and deployment \
4environment, performs static model analysis, and adjusts deep \
5learning models for optimal execution on end-point target devices."
6HOMEPAGE = "https://01.org/openvinotoolkit"
7
8SRC_URI = "git://github.com/opencv/dldt.git;protocol=git;branch=2019 \
9 "
10SRCREV = "ba6e22b1b5ee4cbefcc30e8d9493cddb0bb3dfdf"
11
12LICENSE = "Apache-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 mkdir -p ${D}${datadir}/openvino/model-optimizer
19 cp -r model-optimizer ${D}${datadir}/openvino/
20}
21
22RDEPENDS_${PN} += " \
23 python3-numpy \
24 python3-protobuf \
25 python3-defusedxml \
26 python3-networkx \
27 python3-test-generator \
28 bash \
29 "
30
31FILES_${PN} += "${datadir}/openvino"