summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-02-07 13:59:56 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-02-11 14:32:30 +0800
commit658366aa136ea30b07d6067e9d57c60972de73ad (patch)
treecb65b5cd0d4c1dae3ea1e30543f61fef197594d7 /dynamic-layers
parentf8771831bb368be7eb3575ae68447176cce118ad (diff)
downloadmeta-intel-658366aa136ea30b07d6067e9d57c60972de73ad.tar.gz
intel-compute-runtime: upgrade 19.44.14658 -> 20.04.15428
For more details: https://github.com/intel/compute-runtime/releases/tag/20.04.15428 Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch25
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch49
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_19.44.14658.bb)3
3 files changed, 65 insertions, 12 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
index b886b95d..6f7cdff8 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch
@@ -1,6 +1,6 @@
1From 2475dfc1350f73a243c9fc223a9f06af85321d56 Mon Sep 17 00:00:00 2001 1From ad3e325c1af4d6533fd9b3dfc5208267b678327a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 2 Jul 2019 08:36:34 +0800 3Date: Thu, 6 Feb 2020 18:25:19 +0800
4Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler 4Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler
5 5
6Let us supply the correct path for it to be able to find the correct 6Let us supply the correct path for it to be able to find the correct
@@ -9,19 +9,19 @@ libraries.
9Upstream-Status: Inappropriate 9Upstream-Status: Inappropriate
10 10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12 12Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
13--- 13---
14 runtime/built_ins/kernels/CMakeLists.txt | 2 +- 14 runtime/built_ins/kernels/CMakeLists.txt | 2 +-
15 runtime/scheduler/scheduler_binary.cmake | 2 +- 15 runtime/scheduler/scheduler_binary.cmake | 2 +-
16 2 files changed, 2 insertions(+), 2 deletions(-) 16 2 files changed, 2 insertions(+), 2 deletions(-)
17 17
18diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt 18diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt
19index 5dc9fe1b..e258847d 100644 19index 863dba145..a385cf768 100644
20--- a/runtime/built_ins/kernels/CMakeLists.txt 20--- a/runtime/built_ins/kernels/CMakeLists.txt
21+++ b/runtime/built_ins/kernels/CMakeLists.txt 21+++ b/runtime/built_ins/kernels/CMakeLists.txt
22@@ -51,7 +51,7 @@ function(compile_builtin gen_type platform_type builtin) 22@@ -66,7 +66,7 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options)
23 if(DEFINED IGDRCL__IGC_LIBRARY_PATH) 23 if(DEFINED NEO__IGC_LIBRARY_PATH)
24 set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) 24 set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>)
25 else() 25 else()
26- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) 26- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>)
27+ set(cloc_cmd_prefix ocloc) 27+ set(cloc_cmd_prefix ocloc)
@@ -29,15 +29,18 @@ index 5dc9fe1b..e258847d 100644
29 endif() 29 endif()
30 list(APPEND __cloc__options__ "-cl-kernel-arg-info") 30 list(APPEND __cloc__options__ "-cl-kernel-arg-info")
31diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake 31diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake
32index 1b12592b..ed9f375d 100644 32index a7015b909..a720d2f5c 100644
33--- a/runtime/scheduler/scheduler_binary.cmake 33--- a/runtime/scheduler/scheduler_binary.cmake
34+++ b/runtime/scheduler/scheduler_binary.cmake 34+++ b/runtime/scheduler/scheduler_binary.cmake
35@@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel) 35@@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel)
36 if(DEFINED IGDRCL__IGC_LIBRARY_PATH) 36 if(DEFINED NEO__IGC_LIBRARY_PATH)
37 set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) 37 set(cloc_cmd_prefix LD_LIBRARY_PATH=${NEO__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>)
38 else() 38 else()
39- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) 39- set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>)
40+ set(cloc_cmd_prefix ocloc) 40+ set(cloc_cmd_prefix ocloc)
41 endif() 41 endif()
42 endif() 42 endif()
43 list(APPEND __cloc__options__ "-cl-kernel-arg-info") 43 list(APPEND __cloc__options__ "-cl-kernel-arg-info")
44--
452.17.1
46
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch
new file mode 100644
index 00000000..dbeeb1d3
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch
@@ -0,0 +1,49 @@
1From c5cbcef415b16a8d0168c0d6b9da467d8c4e59a3 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 6 Feb 2020 16:01:39 +0800
4Subject: [PATCH] linker.cpp: fix for missing RelocationInfo.h
5
6Facing build failure with below error:
7
8git/core/compiler_interface/linker.cpp:14:10: fatal error: RelocationInfo.h: No such file or directory
9| 14 | #include "RelocationInfo.h"
10| | ^~~~~~~~~~~~~~~~~~
11| compilation terminated.
12
13Upstream-Status: Submitted [https://github.com/intel/compute-runtime/pull/256]
14
15Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
16---
17 core/compiler_interface/linker.cpp | 2 +-
18 core/unit_tests/compiler_interface/linker_tests.cpp | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/core/compiler_interface/linker.cpp b/core/compiler_interface/linker.cpp
22index a5b0386e9..c1445b336 100644
23--- a/core/compiler_interface/linker.cpp
24+++ b/core/compiler_interface/linker.cpp
25@@ -11,7 +11,7 @@
26 #include "core/helpers/debug_helpers.h"
27 #include "core/helpers/ptr_math.h"
28
29-#include "RelocationInfo.h"
30+#include "visa/RelocationInfo.h"
31
32 #include <sstream>
33
34diff --git a/core/unit_tests/compiler_interface/linker_tests.cpp b/core/unit_tests/compiler_interface/linker_tests.cpp
35index 6bb7e987c..f2d0b5632 100644
36--- a/core/unit_tests/compiler_interface/linker_tests.cpp
37+++ b/core/unit_tests/compiler_interface/linker_tests.cpp
38@@ -11,7 +11,7 @@
39
40 #include <string>
41
42-#include "RelocationInfo.h"
43+#include "visa/RelocationInfo.h"
44
45 TEST(LinkerInputTests, givenGlobalsSymbolTableThenProperlyDecodesGlobalVariablesAndGlobalConstants) {
46 NEO::LinkerInput linkerInput;
47--
482.17.1
49
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_19.44.14658.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb
index ac09ed32..a910ab34 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_19.44.14658.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb
@@ -13,9 +13,10 @@ SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
13 13
14SRC_URI_append_class-target = " \ 14SRC_URI_append_class-target = " \
15 file://dont-use-ld-library-path.patch \ 15 file://dont-use-ld-library-path.patch \
16 file://fix-missing-header-path.patch \
16" 17"
17 18
18SRCREV = "74a5e50339cb58dd62b198763f65aa4987314a59" 19SRCREV = "98006aa2bf282ebc5914359e0e4c5f1c539de56f"
19 20
20S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
21 22