summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-11-04 09:27:53 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-11-05 11:18:25 +0800
commit22b3b365b5c9ebf5ed7e26746279d1c4ed1f0424 (patch)
tree5b6c56cec205f8c2d2e59b25de610354783a0f80 /dynamic-layers
parent84f3d83f41abe93f26e8de4d79f7bee48cf01854 (diff)
downloadmeta-intel-22b3b365b5c9ebf5ed7e26746279d1c4ed1f0424.tar.gz
intel-graphics-compiler: disable vector compiler option
IGC has a copy of legacy spirv translator and additional patcheset to produce spirv shared object (libSPIRVDLL.so) to support Vector compiler. But we build spirv externally and link, which does not provide spirv shared object (libSPIRVDLL.so). Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
index d55e2c61..b4067ed0 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
@@ -32,7 +32,7 @@ DEPENDS_append_class-target = " clang-cross-x86_64"
32RDEPENDS_${PN} += "opencl-clang" 32RDEPENDS_${PN} += "opencl-clang"
33 33
34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}" 34LLVM_COMPAT_VERSION = "${@bb.utils.contains('LLVMVERSION', '10.0.1', '10.0.0', '11.0.0', d)}"
35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0" 35EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=${LLVM_COMPAT_VERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DINSTALL_SPIRVDLL=0 -DIGC_BUILD__VC_ENABLED=OFF"
36 36
37# VectorCompiler doesn't build with LLVM11 as of this release. 37# VectorCompiler doesn't build with LLVM11 as of this release.
38# Re-enable after those issues have been fixed. 38# Re-enable after those issues have been fixed.