summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2020-03-09 17:14:15 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-03-10 06:31:07 +0800
commit0909177b2d7346ef1823d5c1b41bc7da792fa25f (patch)
tree8cf6f43f587e24e282cba358aa44f7330fc718da /dynamic-layers
parent759b79be5aa4ac931d2b779f9c8a19bfb190d6ca (diff)
downloadmeta-intel-0909177b2d7346ef1823d5c1b41bc7da792fa25f.tar.gz
intel-compute-runtime: fix missing header error
In order to include visa/ headers from igc, set IGC_DIR path Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch49
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb3
2 files changed, 1 insertions, 51 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch
deleted file mode 100644
index dbeeb1d3..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/fix-missing-header-path.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From c5cbcef415b16a8d0168c0d6b9da467d8c4e59a3 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 6 Feb 2020 16:01:39 +0800
4Subject: [PATCH] linker.cpp: fix for missing RelocationInfo.h
5
6Facing build failure with below error:
7
8git/core/compiler_interface/linker.cpp:14:10: fatal error: RelocationInfo.h: No such file or directory
9| 14 | #include "RelocationInfo.h"
10| | ^~~~~~~~~~~~~~~~~~
11| compilation terminated.
12
13Upstream-Status: Submitted [https://github.com/intel/compute-runtime/pull/256]
14
15Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
16---
17 core/compiler_interface/linker.cpp | 2 +-
18 core/unit_tests/compiler_interface/linker_tests.cpp | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/core/compiler_interface/linker.cpp b/core/compiler_interface/linker.cpp
22index a5b0386e9..c1445b336 100644
23--- a/core/compiler_interface/linker.cpp
24+++ b/core/compiler_interface/linker.cpp
25@@ -11,7 +11,7 @@
26 #include "core/helpers/debug_helpers.h"
27 #include "core/helpers/ptr_math.h"
28
29-#include "RelocationInfo.h"
30+#include "visa/RelocationInfo.h"
31
32 #include <sstream>
33
34diff --git a/core/unit_tests/compiler_interface/linker_tests.cpp b/core/unit_tests/compiler_interface/linker_tests.cpp
35index 6bb7e987c..f2d0b5632 100644
36--- a/core/unit_tests/compiler_interface/linker_tests.cpp
37+++ b/core/unit_tests/compiler_interface/linker_tests.cpp
38@@ -11,7 +11,7 @@
39
40 #include <string>
41
42-#include "RelocationInfo.h"
43+#include "visa/RelocationInfo.h"
44
45 TEST(LinkerInputTests, givenGlobalsSymbolTableThenProperlyDecodesGlobalVariablesAndGlobalConstants) {
46 NEO::LinkerInput linkerInput;
47--
482.17.1
49
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb
index a910ab34..f6cfaf19 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_20.04.15428.bb
@@ -13,9 +13,7 @@ SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
13 13
14SRC_URI_append_class-target = " \ 14SRC_URI_append_class-target = " \
15 file://dont-use-ld-library-path.patch \ 15 file://dont-use-ld-library-path.patch \
16 file://fix-missing-header-path.patch \
17" 16"
18
19SRCREV = "98006aa2bf282ebc5914359e0e4c5f1c539de56f" 17SRCREV = "98006aa2bf282ebc5914359e0e4c5f1c539de56f"
20 18
21S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
@@ -31,6 +29,7 @@ COMPATIBLE_HOST = '(x86_64).*-linux'
31COMPATIBLE_HOST_libc-musl = "null" 29COMPATIBLE_HOST_libc-musl = "null"
32 30
33EXTRA_OECMAKE = " \ 31EXTRA_OECMAKE = " \
32 -DIGC_DIR=${STAGING_INCDIR}/igc \
34 -DBUILD_TYPE=Release \ 33 -DBUILD_TYPE=Release \
35 -DSKIP_UNIT_TESTS=1 \ 34 -DSKIP_UNIT_TESTS=1 \
36 -DCCACHE_ALLOWED=FALSE \ 35 -DCCACHE_ALLOWED=FALSE \