summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-11-20 23:15:21 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-11-21 00:03:37 +0800
commit05da12b7667c098b5bee5be5b9b896410438ce1a (patch)
tree7eb835e6702ad3bcb889c8f94945562a8129e52f /dynamic-layers
parentfeb0e8a5cd1ba1f609786b9ab2e20bd3283be091 (diff)
downloadmeta-intel-05da12b7667c098b5bee5be5b9b896410438ce1a.tar.gz
intel-graphics-compiler: upgrade 1.0.5176 -> 1.0.5435
Release notes: https://github.com/intel/intel-graphics-compiler/releases/tag/igc-1.0.5435 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch29
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb)2
2 files changed, 16 insertions, 15 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
index 7612b181..c694836f 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/improve_src_package_reproducibility.patch
@@ -1,4 +1,4 @@
1From 88b961ce4e2c9744631c51d13fa638e8a8a6c2a9 Mon Sep 17 00:00:00 2001 1From 2fa3f2da1179bd5b2eeac82839d386f0111e611c Mon Sep 17 00:00:00 2001
2From: Lee Chee Yang <chee.yang.lee@intel.com> 2From: Lee Chee Yang <chee.yang.lee@intel.com>
3Date: Wed, 2 Sep 2020 08:28:35 +0800 3Date: Wed, 2 Sep 2020 08:28:35 +0800
4Subject: [PATCH] Improve Reproducibility for src package 4Subject: [PATCH] Improve Reproducibility for src package
@@ -10,26 +10,27 @@ before adding the flags.
10Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream] 10Upstream-Status: Inappropriate [applying --file-prefix-map in such way does not work for upstream]
11Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> 11Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com>
12--- 12---
13 visa/CMakeLists.txt | 7 +++-- 13 visa/CMakeLists.txt | 7 +++++--
14 1 file changed, 5 insertions(+), 2 deletions(-) 14 1 file changed, 5 insertions(+), 2 deletions(-)
15 15
16diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt 16diff --git a/visa/CMakeLists.txt b/visa/CMakeLists.txt
17index 9c169592..ecea91db 100644 17index 981c35d2..d5944370 100644
18--- a/visa/CMakeLists.txt 18--- a/visa/CMakeLists.txt
19+++ b/visa/CMakeLists.txt 19+++ b/visa/CMakeLists.txt
20@@ -105,8 +108,11 @@ endif() 20@@ -109,8 +109,11 @@ endif()
21 # Set up the bison and flex targets. These commands will set up commands to generate the appropriate 21 set(bison_output_file ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp)
22 # source files from the input grammars. It will also set up the dependencies correctly for any 22 set(flex_output_file ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp)
23 # library or executable that uses the generated source 23
24-BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-vt -p CISA") 24-BISON_TARGET(CISAParser CISA.y ${bison_output_file} COMPILE_FLAGS "-vt -p CISA")
25-FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA ${WIN_FLEX_FLAG}") 25-FLEX_TARGET(CISAScanner CISA.l ${flex_output_file} COMPILE_FLAGS "-PCISA ${WIN_FLEX_FLAG}")
26+if(BISON_VERSION VERSION_GREATER_EQUAL "3.7.0") 26+if(BISON_VERSION VERSION_GREATER_EQUAL "3.7.0")
27+ set(BISON_EXTRA_FLAGS " --file-prefix-map=$ENV{B}=/igc/ ") 27+ set(BISON_EXTRA_FLAGS " --file-prefix-map=$ENV{B}=/igc/ ")
28+endif() 28+endif()
29+BISON_TARGET(CISAParser CISA.y ${CMAKE_CURRENT_BINARY_DIR}/CISA.tab.cpp COMPILE_FLAGS "-l -vt -p CISA ${BISON_EXTRA_FLAGS} ") 29+BISON_TARGET(CISAParser CISA.y ${bison_output_file} COMPILE_FLAGS "-l -vt -p CISA ${BISON_EXTRA_FLAGS} ")
30+FLEX_TARGET(CISAScanner CISA.l ${CMAKE_CURRENT_BINARY_DIR}/lex.CISA.cpp COMPILE_FLAGS "-PCISA -L ${WIN_FLEX_FLAG} ") 30+FLEX_TARGET(CISAScanner CISA.l ${flex_output_file} COMPILE_FLAGS "-PCISA -L ${WIN_FLEX_FLAG} ")
31 ADD_FLEX_BISON_DEPENDENCY(CISAScanner CISAParser) 31 ADD_FLEX_BISON_DEPENDENCY(CISAScanner CISAParser)
32 set(CISAScanner_dependencies)
33
34--
352.28.0
32 36
33 add_custom_target(CISAScanner_target DEPENDS ${FLEX_CISAScanner_OUTPUTS} ${BISON_CISAParser_OUTPUTS})
34--
352.25.1
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb
index b4067ed0..502200fa 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5176.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.5435.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https; \
14 file://improve_src_package_reproducibility.patch \ 14 file://improve_src_package_reproducibility.patch \
15 " 15 "
16 16
17SRCREV = "3e7c8e95b48a4eb6637077c52ff253a37b5ea085" 17SRCREV = "93f02a7dfa37d879abc2ff5d62fd1e527fa4b03a"
18 18
19# Used to replace with relative path in reproducibility patch 19# Used to replace with relative path in reproducibility patch
20export B 20export B